Lightburn bridge not connected to Creality laser

This is my first question to the forum.

I have a Creality 5W laser and have lightburn installed on my MacMini running os 14. I have trouble keeping the usb connection working so am trying lightburn bridge. After the bridge wizard completes its search it finds the bridge on my PI 3B but the laser is not connected to the bridge. I have tried re-installing the bridge on the pi, have added the wifi.txt file and am using the same usb cord between the pi and laser which worked from the Mac to the laser. How do I get the pi/bridge to connect to the laser controller?
The Wizard report is “No Laser Connected - Lightburn Bridge - IP 192.168.2.244”.

Per the Bridge doc:

The LightBurn Bridge is only for use with lasers using Ruida controllers.

Creality lasers have GRBL (-ish) controllers, not Ruida controllers, so you can’t get there from here.

That certainly explains my problem, you can tell I am totally new at this. Thanks for your help, I will continue with a USB connection and put up with dropped connection. Once I understand Lightburn better I will simple use a micro SD card for file transfer.
Cheers

Everybody starts out there, so don’t feel bad! :grin:

Welcome aboard …

1 Like

Welcome to the site…


Most people find sneaker net a poor option… Suggest you solve the USB communications issue.

:smile_cat: