Lightburn bridge not working while Windows VPN is connected

I write this topic today as I have successfully installed my Raspberry Pi on my Co2 laser, with RuiDa controller on it, and Lightburn bridge software. I’m using an Acer Predator, running Windows 11.

My problem is that when I’m connected to my distant server (Windows VPN, for work), Lightburn bridge doesn’t work. When I disconnect the VPN, everything works fine.

I already modified my VPN settings to use my local network for internet connection, so it’s just to transfer and get my files from this server.

Any ideas on how to fix that?

Thank you

Can you describe your network topology? Specifically, are you connected to LB Bridge with the same network card and IP that you use to connect to the internet?

Can you elaborate on this? Have you allowed local networking while on VPN? If so, are you able to connect to other local network resources? If not, you’ll need to allow for this otherwise there is no chance this will ever work.

What specific VPN software and protocol are you using?

It’s a L2TP protocole created directly on Windows. I unchecked the “Use default gateway on remote network” box in my IPV4/IPV6 advanced settings to use my local internet connection while using my VPN access. (as mentionned in this step-by-step process: Accessing Local Network Resources While Using VPN - Spiceworks)

I verified, and that’s correct, I’m using my local network connection. What do you mean by “other local network resources” ? I don’t have other things connected on my local network to check this, and I’m not really skilled in “computer science” things.

I was hoping you had other LAN computers or printers or something else you could verify were working.

The “use default gateway on remote network” will allow for split tunneling but there may still be something missing.

Some additional questions:

  1. Can you try fully disabling any firewall running and retest?
  2. Are you using L2TP with cert or pre-shared key or something else possibly?
  3. What’s your local IP for computer and Bridge?
  4. Can you run this command in a Command Prompt with both VPN disconnected and connected and return results?
route print /4

Unfortunately not :).

  1. I tested it, and that’s the same, so probably not a problem with Norton.
  2. Yes, it’s a pre-shared key
  3. I’m not home now, so I can’t actually check at the moment.

VPN disabled

VPN enable - (Interface 37 “L1mprimerie” is my VPN connection).

Without VPN

Thank you

Once you can confirm your IP addresses that will be helpful.

There are a few things going on in the VPNed view that are interesting for me.

  1. Do you know what the address is?
  2. There is a address as Gateway (Adr. passerelle). Do you know where this came from?
  3. I didn’t realize you’d have a public IP in the list. You may want to edit this post and blur-out the address on the first column fifth row of the screenshot.
  4. When you have a chance, can you try pinging the IP address of the Bridge from your computer while connected to VPN? Try running these commands in Command Prompt:
tracert -d BRIDGE_IP_HERE

My PC ip is:
Bridge ip is:

  1. I don’t know, maybe my wife’s phone… I don’t know. :face_with_peeking_eye: EDIT: It’s my distant server, as I tested ping this IP with and without VPN activated.
  2. I don’t know neither. EDIT: As mentionned at the last screenshot of this post, it seems to be the distant server as well. On my first screenshots, you can see that and are the same thing.
  3. Thank you, I hope I hide the correct ones :slight_smile:

While not connected to VPN:

ping bridge ip

While connected to VPN: Failed. 100% lost, and then, there is, you asked about back at point 2. , appearing, so it’s probably the distant server ip?!


Can you run this as Admin in Command Prompt:

route -p add MASK METRIC 15

Then test to see if you can connect to Bridge?

While VPN is off, it’s written “OK!”
While VPN is on, it’s written that the object already exists.

And tried to send something on lighburn to my laser, and still the same message, no lightburn bridge found. :face_with_diagonal_mouth:

Can you run these commands in Command Prompt with VPN on?

route print 192.168* /4
tracert -d

I think the reason you got this was because the new route is permanent. So the second time you did it there was already a route added so gave you the error message.

Yes, you are right, it makes sens.
(tell me if I should hide some of the ip here)

Capture d’écran



“Impossible to join the destination host”, with vpn on.

I specifically filtered for only local hosts so should be okay.

Can you try re-enabling the “Use default gateway on remote network”? Curious if this will change anything.

Then rerun the same commands please.

Ok, nice, thank you :).

I re-enabled the “Use default gateway on remote network” and it works. Both commands and connexion with my bridge. But the reason I unchecked that “Use default gateway on remote network” is that I need to use my own local network to surf on internet, instead of using the distant connexion for that, even when my vpn is on.

Edit: After your suggestion. I unchecked again the “Use default gateway on remote network” and checked the checkbox just under this one, it’s “disable class based route addition”. And now I’m still connected on my local network for internet and Lightburn find my bridge directly, but I can’t have access to my distant server with this option.


Ah, I didn’t realize you wanted to bypass the vpn for internet requests as well.

This is because the necessary routes for the VPN are not automatically added with that optoin. You will need to add these manually in that case.

Can you do this? Uncheck “Use default gateway on remote network”, uncheck “disable class based route addition”. Then run this command and direct message me the results. Don’t post here.

route print /4
1 Like

Yes, sure. Thank you

Here is the solution, running command as administrator:

Now it works perfectly with or without VPN activated.

Thanks again berainlb for your time and help !

Glad you sorted it out. I’m curious, though. Is your bridge IP not dynamic?

EDIT: got your DM and that cleared it up. This was a different “bridge” than I was remembering.

1 Like