Lightburn Bridge with Ruida RDC5121 controller

I think I know the answer to this question, but hopefully I’m wrong. Will the bridge work with a Ruida 5121 controller (no Ethernet on-board)? I was hoping that the laser could plug into the USB port on the Pi, and this would give me Ethernet/WiFi capability, because I’m having connectivity issues with my laser and my Windows machine.


I didn’t realize that controller existed. But as of now, no ethernet = no Bridge.

If you’re having connectivity issues with direct connection not sure if a remote connection through USB would help. Unless there was something specifically wrong with the USB ports on your computer.

Well, I’m using the same computer that I was using with my old laser (which also had an RDC5121 controller). No problems for about 9 months.

Picked up an upgrade laser (same manufacturer, but much bigger), which has the same RDC5121 controller. Same computer on my side. When I try to send files to the laser, I regularly get anywhere from 2 to 10 failed attempts to send before it finally goes through. Very frustrating. Tried different cables. Tried connecting directly to the controller USB (bypassing the USB plug on the laser). Tried different USB ports on my computer. Plugged a powered USB hub in between. Tried USB packets instead of serial. Nothing changes. Was hoping that the Bridge would give me another option, but apparently not.

I’ve got a “USB isolator” on the way today; we’ll see if that addresses the issue. Can also try a different computer, but that’s not ideal. Otherwise, it’s a new controller, I guess.


Do you still have the older laser? Could you swap the controller to see if it’s something unique to the controller? You’d want to do a full backup of both controllers before.

Based on your description definitely sounds like something on the controller side since that’s the variable that’s changed.

Nope, that laser has gone onto a new home.

The previous owner of my new laser says he never had any connection issues. I don’t have any particular reason to mis-trust him, and I did see it working at his place without an issue. At my place, it’s virtually EVERY time I try to send something, so it would have been difficult to hide if he was having the same issue.

Ha. I’m sure the reverse is true. You would have heard about it plenty if he did have issues.

It’s a shame about the connection issues especially since you had one working reliably with the same gear. Would be nice to be able to isolate the issue down to one component.

Yeah, we’ll see how it goes… If the USB isolator doesn’t fix it (one of my local laser resources suggested it might help on Dell computers, which I’m using), then I guess my next option is a controller upgrade. Which is quite a bit more expensive, and doesn’t really give me a bunch more functionality. At least, I can’t see from the spec sheets that I’m gaining much going to a 6442 or 6445 controller.

And in that case the Bridge would be an option if you wanted to get away from being tethered.