Lightburn bug which os running my machine 10x faster than it should

I have been running light burn generated g-code on my openbuilds acro for many months now, and recently, I moved my license to a new computer, and for some reason, now the code is running the laser at 10x the feed-rate than before and I can’t stop it or change it? Please help as these are production machines and we’re now stuck until this is fixed!!! Am running GRBL 1.1g and using openbuilds controller to run it as always…

I’ve run a comparison test on a lightburn file that I previously (before copying the license to this compter) saved g-code for a little while ago (which runs perfectly). Then I re-saved the g-code in the current lightburn and it smashes the laser around at 10x speed! Have looked at the side by side gcode and it is different???

Help to get this foxed is much appreciated…

Can you upload the two gcode files for comparison?

How did you configure the device profile on the two installations?

Are you running the same version of LightBurn on the two installations?

Have solved the problem, turns out that a critical setting had been changed in the lighburn settings - the mm/sec or mm/min!!! Please lighburn developers, this is a critical setting to make a default change to, without notification, and really messed us up for a bit, not to mention caused us a pretty messed up afternoon trying to find out what the heck was going on. So as feedback, this option ABSOLUTELY must be on the machine setup list - so it is set and fixed, and not left for someone to dig around for hours trying to found out why things aren’t working!

The mm/min or mm/s are set in Lightburn and have to equate to the machines settings.

I assume you loaded a new copy/version of Lightburn, so it will come with the defaults. This should have been done when you setup the new copy.

How would you suggest it know what you are using?


This still doesn’t fully make sense. Cut layer feed rates are stored in the design and should be preserved irrespective of display units.

This should have only been a potential issue with new cut layers but would still be prominently displayed with the actual units.

Then perhaps you could explain to me why one copy (neither of which were used to actually run the machines (I copy g-code and run in a separate controller) ran at the right feeds, the second (setup exactly the same machine configuration) had different rates - neither of which was taking any other information from the machine they were used on. It seems to me that when I downloaded the most recent copy (after deactivating on one computer to transfer to another) the default setting of units (either mm/s or mm/min) had changed. And so light-burn was coding feed-rates based on mm/sec and not mm/min as it was before. Hence my original comments. Nothing had changed in the actual lighburn file (after moving lightburn from original computer to the other) except to move one piece of geometry around and then recompiling the g-code. So this seems to be a setting that has been changed outside that which the initial machine setup has control over…

At first glance, looking at g-code, I missed it as the values (as you point out) are stored in the cut layer and so written in the g-code, and were the same, but it was the UNITS of the feedrate that had changed, not the values! So instead of the compiling the cut rate of say 500mm/min, it was compiling a rate of 500mm/sec! All due to the fact that even though I setup the lightburn machine type exactly the same, the default setting for feedrate units had changed from mm/min (which was how it was on my original computer - I never changed or set this up) to mm/sec…

1 Like

This is what I don’t understand. Feed rate should have converted in the design. For example, if my LightBurn settings are setup for mm/s and I send you a design with feed rates at 100 mm/s. When you load it on your system setup for mm/min it should show that as 6000 mm/min.

I’ve been assuming you’re changing this in Edit->Settings. Is that correct? If so, the units listed there only impact how units are displayed, they don’t impact the actual speed. So you can move back and forth to any display unit. The absolute speeds remain the same.

There must be a very specific set of events that somehow got you in a situation where the values are getting interpreted in one set of units vs another… but it’s likely not from Edit->Settings.

It surprised me as well. But tried an older lighburn file, complied on my previous computer, didn’t make any changes, but just saved it to g-code and the same thing happened. It sent the laser around 10x faster than it was set to. Then, after I found the units settings in lightburn (see screen shot), changed them from mm/sec to mm/min, then the values in the cutting layers suddenly changed to 60x the numerical values before. I changed them back to where they were supposed to be and that solved it. So although the values hadn’t changed in each layer, the units used in lightburn had been. So my issue is that the new version of lighburn I activated on the new computer defaulted to the CO2 version of units, mm/sec (see screen shot), rather than the previous version which defaulted to the Diode laser units, of mm/min. This simple switch caused all the issues and it most definitely had the effect of multiplying the actual speed of the laser movement considerably of course…

I suspect the issue isn’t specifically that the units defaulted to mm/s since your cut layer settings should be absolute speeds and this only is meant to set how they are displayed. There’s likely some corner case where possibly for a new install that speed settings on an existing design were not getting converted according to the set units and simply using them directly.

What version of LightBurn was your previous installation? Maybe it’s possible that units were handled differently at that time.

In looking at a .lbrn2 file it looks like speeds are stored as a value with assumed units of mm/s. That means LightBurn must do the conversion on the fly for all other units.

I’ve tried swapping units in various ways and can’t get it to not behave properly. I suspect if you switched back to mm/s you wouldn’t be able to reproduce it at this point. Would be nice to be able to isolate it to a specific condition.

Thank you!!!
I have been searching and asking for a couple weeks.
I couldn’t firgure it out for the life of me.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.