Lightburn burns everything way too big!

I have a DIY laser diode machine frame 400mm x 400mm working area with a Eleksmaker Mana SE controller running grbl 1.1h and a Neje n40630 laser. As an example I can type " hello" and the dimensions are 53.xx by 18.xx in Lightburn…when I start the machine… what is burns is almost 3 times that size. This happens with everything I try to burn. I need some help please. I am new to Lightburn. Many thanks!

You’re most likely dealing with a situation where you GRBL configuration is incorrect for your laser.

Specifically, the steps/mm configuration described here:

$100, $101 and $102 – [X,Y,Z] steps/mm

Grbl needs to know how far each step will take the tool in reality. To calculate steps/mm for an axis of your machine you need to know:

  • The mm traveled per revolution of your stepper motor. This is dependent on your belt drive gears or lead screw pitch.
  • The full steps per revolution of your steppers (typically 200)
  • The microsteps per step of your controller (typically 1, 2, 4, 8, or 16). Tip: Using high microstep values (e.g., 16) can reduce your stepper motor torque, so use the lowest that gives you the desired axis resolution and comfortable running properties.

The steps/mm can then be calculated like this: steps_per_mm = (steps_per_revolution*microsteps)/mm_per_rev

Compute this value for every axis and write these settings to Grbl.

LightBurn provides a way of calibrating these settings if you go to Edit->Machine Settings->Calibrate Axis.

Or else you can calibrate by hand and update the GRBL configuration.


Maybe you have set the controller to inches instead of mm? 1 inch = 2.54cm so almost 3x bigger…

1 Like

Thanks very much for your assistance…I will do that this afternoon.

As far as I can tell both Lightburn and the controller are set to mm. in GRBL $13=0. In Lightburn Units/Grids are set to mm/min. Apparently, in an older version (?) of GRBL…$20 and $21 were the inch/mm settings. There has to be something I have missed…thanks for your help!! Your reasoning was spot on though as the burn is almost three times as large.

Thanks very much…that fixed it! I don’t really understand why it was that far off…but it works now at any rate. Thanks! By the way…I used the calibrate axis within Lightburn.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.