Lightburn Camera on Mac 10.13.6 - No Image after working before

Hello, Bought a camera from lightburn and used it with an imac with no problems for a week. Unplugged everything to reposition the laser. Now the imac recognizes the camera but it does not pull the image into lightburn. Tried on a windows computer and it works. Rebooted. Changed resolution. iMac still does not pull image from camera.
Any ideas?

Which camera did you get? And, is LightBurn authorized to use the camera? Does the camera work in other apps on the Mac, like Facetime? (that would rule out an issue with the cam itself)

Lightburn camera 160 degree. Worked great for a week until I unplugged.

Facetime recognizes it too but no image.

I looked in preferences and don’t see any option to allow authorization.

It worked before I unplugged and moved things. Any other ideas?


Problem solved. Swapped out USB extension cable and it works. Not sure why it worked w/ windows and not mac. Thanks!

Standard extension cables shouldn’t be used for the camera - you need an active / amplifying extension, which is basically a one-port USB hub that repeats the signal, not just extends the wires. USB is only rated for 16 feet (5 meters).

1 Like

It’a not Windows vs MacOS, it’s your PC manufacturer vs Apple.

The chipset your PC uses to provide USB will be different to that of your iMac, with different characteristics. Apple tends to be more stringent with standards than a lot of PC manufacturers, many of whom just integrate third party parts.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.