LIGHTBURN cannot find my laser device

I have a YOFULY laser recently purchased from Amazon. I built the machine as the instructions said and think I did a good job. I connected it to the computer. Lights came on near the back so I know I had power. I plugged it in and my computer listed “starting up new device”. I then started LIGHTBURN. It said it was searching for the device, but after 5 attempts I realized there was a problem. What am I doing wrong and how do I correct this?

The machine is listed on Amazon as YOFULY-

2-in-1 Upgrade 3018 Pro-M CNC Router Kit, 5500 mW CNC Engraving Machine GRBL Control 3 Axis PCB Milling Machine, Wood Router Engraver with Offline Con

—DAN

Is the offline controller connected? If so, it will not talk to the PC. If it came with stock software, there might be drivers included to get the PC to see it, so you might need to install those.

I too am having problems. I have the elks maker A3 and bout lightburn and when I start it up it can’t see my lase. It works in Abe box just minor issues so I bout lightburn. I tried several ideas given via Facebook group for port and nothing works can’t find laser no matter what I do. Help!

What is “Abe box”? Did you mean Benbox? If so, that uses its own custom firmware, not GRBL, so you’d likely need to flash the board with GRBL firmware first.

This might help: Arduino Based cheap laser engraver help please

I have the “MYSWEETY” 3018 PRO with 5500mW (5.5W) laser. To make sure the device driver is loaded, go to device manager and make sure there is an entry under Ports (COM & LPT) that says USB-SERIAL CH340 (COM 3).
Your com port number may be different but whatever it is, use that number for the comm port you tell Lightburn to use.
You may also have to click the arrow (>) beside the Ports listing in device manager to see your CH340 driver and it will ONLY be visible if your computer is connected to your control board.
I hope this helps. I’ve used LaserGRBL in the past and I’m downloading Lightburn tonight because of all the good press it is getting in various diode laser groups I belong to. LaserGRBL works well as far as what it does but the feature set in Lightburn is drastically better and is likely going to make purchasing it after my trial a no brainer.

Good luck.

To start, I have only been doing this for less than 24 hours, so please have patience with my ignorance. i am using a YoraHome 6550 with 15w laser. I hooked it up to GRBL and able to fumble through some burns. I downloaded Lightburn and have been trying to figure it out by youtube and google searches for about 6 hours (needless to say how frustrated I am). Lightburn says it “Ready” but I can’t get my laser to do anything.

Does “Ready” mean I’m connected and if so any ideas as to why i can’t get it to move the laser

I would like to suggest you have a review of this documentation for first time users. We walk you through the initial setup and a simple project to show you how LightBurn works when set properly for your system. Take a read and post back, we can go from there. https://lightburnsoftware.github.io/NewDocs/FirstTimeSetup.html

hey Rick,
thanks for the link it was very informative but did not solve my main problem. it appears Lightburn and my laser are communicating but every time I try to start I get error message “There was a problem sending data to the laser. The machine may be busy or paused.” I have disconnected from GRBL and tried with the same error msg, and I have left GRBL running and tried with the same error msg.

Any ideas?

Thanks.

What do you see in the console window after choosing a COM port? The “machine may be busy or paused” message will sometimes happen if GRBL locks you out after trying to send it out of bounds, but the console will show error messages and feedback from the controller itself.

I have been using my Yorahome 6550 with Lightburn with no real issues for several months now. I haven’t operated the machine in a couple weeks now, and despite having no issues the last time I did a burn, my laser will not connect to Lightburn now. I have tried reinstalling the driver software and that did not fix it.

The console just says “waiting to connect” as the Laser window says disconnected. When I click Find my laser it is able to find the laser but still will not connect. What is my next step please? Thanks for the assistance.

Try this, Shift-click the ‘Devices’ button.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.