Lightburn changes the size when engraving or cutting

Hello everyone,

Unfortunately I have not found anything in the forum and therefore allow myself the following question.

Lightburn suddenly changes size when engraving or cutting.

Except for the regular updates, I have not willfully changed anything in Lightburn or on my CO2 laser. Before that, everything was accurate to the millimeter.

I have not set or changed an offset.

I am already looking for 3 days and do not know where I can control or adjust something so that everything is correct again.

The picture is with mm

I hope someone can help me.

Have a nice weekend together


If you mark a 50mm square, how big is the output result? Is the scale off on both axis, or just one?

1 Like

Currently it is as follows for a 50mm square

X = 49.53 mm
Y = 54.16 mm

now I have an even bigger problem.

I tried to calibrate the axes to fix the error, now the laser whispers completely as it wants. Stupid as I am, I have not saved or photographed the file beforehand.
Oh man, can someone help me please?

I would reach out to the supplier and ask for a backup file of the original controller settings shipped with this unit. They should have what all the information about how they first set it up. If they cannot supply a backup file, this might help: Configuring a Ruida - LightBurn Software Documentation

LightBurn actually saves a backup copy of your settings whenever you edit them. Click File > Open prefs folder, and look in the ‘Backup’ folder in there.

The files will start with the name you gave your laser (probably Ruida), and then a datestamp, with the “lbset” extension (LightBurn Settings file).

Copy a recent one out of that folder to somewhere you can find it, like your desktop, then go back to Edit > Machine Settings, click ‘Load’, open that file, then click ‘Write’ to store those settings back to the controller.

1 Like

And of course this ^^^ above. :wink:

Well how cool is that! And I learned something new today. :slight_smile:

everything works as it should.
Thank you for the help!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.