Lightburn co2 laser

I have a Ortur laser master 3 and a new Monport k40 pro co2
If i run my olm3 at 15000 mm/min it takes roughly 10 minutes to engrave the portrait on slate.
If i change nothing for the image and run it on the co2 and put 250mm/s into Lightburn the co2 takes 29ish minutes.
What setting am i missing that is causing this huge change, because the co2 max speed is 350mm/s. i tried changing the co2 speeds a couple times. i can go slower but seems to be that 160 is the max speed Lightburn is putting out to the laser.
not sure if this is a Lightburn issue or Monport issue. based on some other problems i am having with the monport to Lightburn connection it is probably monports fault.
my diode doesn’t have these issues with Lightburn

What is your max speed setting for CO2?
It would be $110 and $111 in grbl settings.

gcode


Basically any speed above 160mm/s runs about the same time.
anyone have any ideas. i have check $110,111, 120 and 121.
I am having power issues as well. Monport thinks it is caused by the power supply or the motherboard. i am still waiting for engineering department to way in. laser maxing at 25%. They haven’t given a possible reason for speed issue.

Are you using overscan? If so, the larger distance required to travel at higher speeds may account for the difference in time.

LightBurn in no way determines the actual speed that your machine travels. It only requests a speed. It’s up to the controller and the hardware to achieve the speeds requested.

Compare speed and acceleration settings between your diode and co2 lasers. Acceleration is likely to be the limiting factor.

Next issue is whether the machinery is capable of meeting the speed and acceleration setting limits defined in the GRBL configuration.

Very little over scan and I kept all the parameters the same for both engraves. I’ve have checked all Lightburn settings. I am thinking it is an issue with the motherboard. Seems to be quite a few people with problems with recent Monport k40’s. I really like the Lightburn software , been using it for a few years now. If i set my diode at 21,000mm/min which would equivalent to the 350mm/s, the monport 3:25 for the engraving in the picture. The same engrave would be 1:29ish using the diode settings.
The preview times given by Lightburn were accurate too, on the monport. When i put 160mm/s in the preview said 3:25. It was right When i increased the speed tom 350mm/s the preview said 3:36. It was right again. So the software has to have something wrong coming from the controller into Lightburn right?

The GRBL configuration setting says 500mm/s max for x and y. but the machine max speed is 350mm/s. i tried adjusting those but it made no difference

Can you show a screenshot of what you’re referring to? Unclear based on this.


$120 and $121. Machine says 500mm/s for max speed but i checked the manual it says max speed for this machine is only 350mm/s

You’re comparing acceleration to speed.

The max rate looks like 20,000 mm/min which is 333 mm/s. So still a discrepancy but not as large.

I also question the fact that X and Y configurations are the same. X should be faster than Y.

Most recent email response from monport today was that the motherboard is faulty and they are working on issuing me a new motherboard. This is for the power issue. They are still working on the speed issue. Could the mother board also be the at fault for the speed? I think a ran a test at 333mm/sec and it was within 10 seconds of the engrave done at 160mm/s. Thank you for your incite on the issue