Lightburn & Cohesion 3D in Window 10 new issue

On Friday Microsoft forced an update of Windows 10 onto my PC and now when I go to use Lightburn with my Cohesion 3D controller on K40 things are not going right.

I can home no issue and can send the head to any position from the Move tab without any problem.

However, when I send a project at the laser it starts engraving in an obviously wrong location and if i let it go for long it will slam the head against the zero X rail and then proceed to another area.

I hate grinding belts so i haven’t been letting it go that far on my trouble shooting.

I Thought it might be a bad file, so I have tried multiple created in Lightburn test patterns to see if this was it and had same result.

Things i have tried with same problem:

  1. Rebooted everything multiple times and restarted in different orders
  2. Downloaded and loaded the latest firmware from Cohesion 3D
  3. Renewed my Lightburn license and downloaded and installed the latest version
  4. Installed the USB/Serial driver with Lightburn
  5. Checked all cables and belts

Would appreciate anyone’s assistance on this.

Many thanks,

So I’m no gCode expert but it would appear from this screen grab that lightburn is sending plausible location. The actual path the laser head follows on is only gets the x to about 85-90mm. I had it hold position after the cut and read the position, it thinks it is at the proper location of x140 y90.

Problem solved! Loading new smoothie cluster firmware on Cohesion board fixed the issues.

1 Like

Update to this. Turns out the SD card i was using was the main problem causing all the fuss. I cross posted this on Cohesion’s forum so if others have the above issue they should try using a new SD card to correct the problem.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.