Lightburn crashes when i use offset-fill... pls help a newbie out

Whenever i use offset fill and try to preview, save .rd or hit run it, the program crashes.

Ive only been using this software (and my laser) two weeks, no idea how to fix this from happening, but I know it shouldn’t be happening!

Please help :slight_smile:

You are correct, LightBurn should not crash. :slight_smile: Do you get a report presented? We would like to see that, so we have a better understanding of what happened.

If you are willing, post the LightBurn file here for review as well, or you can email to support@lightburnsoftware.com, with a link to this post for context.

Sadly, no report! Only what is shown in the screenshot, shows not responding and then i have to force shutdown, but no codes or other msgs

Hi Angie, Have you tried changing the top layer to ‘fill’ instead of offsett?

I have tried to change it, but it just fills the whole island, unless I am doing it wong …

VANCOUVER ISLAND WALL ART - back board.lbrn (1.3 MB)

Here is the file that is not working for me

Hi angie, it also crashed on me too.
I changed the ‘offset’ to ‘line’ and everything works fine.
If your trying to get the outline of the island thicker you can use the ‘offset shapes’ and try something like 0.4 outward, select the inner line then the outer line and ‘group’ then select fill. It works on mine. Or you could do it ‘out of focus’ by lowering the bed a couple of mm so it burns a slightly thicker line.
try it on a piece of waste material, see if it gives you what your after.

1 Like

Hi Rick, did the same to me, just crashed the whole thing.

Thank you for reporting this. I am having an issue with this file as well. Investigating…

1 Like

I am seeing a bunch of duplicate shapes in this file. I moved and placed the duplicates of the red shapes into the black layer to see them.

Zoomed into one of the shapes.

I will forward to the dev team for further review. :slight_smile:

1 Like

Hey kris, thankyou for testing the file! Oh that is a great idea, I will try that, I think I was selecting the wrong ones when I was trying to accomplish something similar. I am definitely trying to get the outer line to be thicker. But since I had already started running the file before I realized the lines were too thin, I could no longer move the material or do any other jobs until it was complete!

OK! So I had used the offset shapes tool on the left side toolbar and then also selected offset fill for the setting of the [02] shapes. I thought this is what I needed to do to make the outlines of the island thicker… incorrect I am guessing!

Thank you very much for your help :slight_smile:

I’ve created a monster. :flushed:

So this is what it was doing to me before when I didn’t understand how to use offset method

and now it is fixed! This is exactly what I was trying to do! :slight_smile:

Thanks so much, both of you!

“Offset fill” works like this: Offset Fill Settings - LightBurn Software Documentation

So if you had used the ‘Offset’ function to create a pair of outlines to fill in between, that would have probably done what you were after.

As it was set up before, it was trying to use the ‘Offset Fill’ function to fill the entire island, not just a thin outline, and at 36" wide, it’s quite large - that would generate a LOT of offsets, and they’re expensive to compute, which is why it was taking so long. Using normal ‘Fill’ is much less compute heavy, and better suited for really large area jobs.

Clicking the ‘Offset’ button generates a single offset (or one inward and one outward, if you set it that way) and it takes much less time. Offset fill is basically generating inward offsets one at a time until the entire shape is filled - it can take quite a while.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.