Lightburn does not cut diagonal, but makes a rectangle

hello,

I am Danilo and work with my Emblaser 2 diode laser for 6 weeks.

With Lightburn I am very happy, but now I realized a bug.
My machine does not cut the slightly diagonal line, but it cuts a rectangle.
See attached pictures.


Does anybody know, if it is Lightburn or my Laser machine, which uses smoothieware?

Hope for good hints.
best regards, Danilo

Sorry this does not answer your question but isn’t that metal tubing blocking your air vents?

No, I think there is no mechanical block. In the MDF cut you see, that the cut is first going left shortly, then going the whole length straight in 90 degrees angle.

Would it help to see the GCode - just to exclude Lightburn or Emblaser? Does anybody know how to read?

Just made a try by cutting only this part of cut line (orange line) and it is straight and not follow the slight angle.

The corresponding GCode is this: sorry, as a new user I cannot attach this file :frowning:
; LightBurn 0.9.15
; Emblaser 2 / Core device profile, absolute coords
; Bounds: X31.57 Y35.35 to X436.12 Y46.61
G00 G17 G40 G21 G54
G90
M3
; Cut @ 80 mm/min, 100% power
M08 S128
G0X31.57Y35.35
G0Z6.5
; Layer C02
G1X31.7S1F80
G1X31.84
G1X31.97
G1X32.1
G1X32.24
(…)
G1X435.72
G1X435.85
G1X435.99
G1X436.12
G0Z8
M09
G1 S0
M5
M2
G21
G0 Z50
; return to user-defined finish pos
G0 X0 Y300
; beeeep-beep-beep
M911 G4P0.5
M912 G4P0.1
M911 G4P0.1
M912 G4P0.05
M911 G4P0.1
M912

There is missing the Y-coordinate upper and below of “(…)”
Can somebody confirm that? I just tried an example with the corner left and there a X- and Y-coordinate is in GCode.

So, seems to be a bug in lightburn?

best regards, Danilo

I know what’s causing this and have fixed it. For now, if you turn off ‘improve smoothieware pausing’ in the Device Settings it will hide the error.

hi,

I will try it.
do you mean this:
image

best regards, Danilo

1 Like

yes, it works. What is the side effect? is it slower? Can I enable it with next Lightburn version?

Thanks for support!

The only side effect is that if you click the Pause button, it will take longer for the machine to pause.

Smoothieware does not have a pause command, so we just stop sending commands to it, but it has to process all commands in the internal buffer before it will stop moving. This ‘improve pause performance’ button chops up long moves into shorter ones, so the controller will process them sooner, but I screwed up how I track rounding errors when many moves in a row are very close.