Lightburn does not recognize my USB ports

I’m running the newest version of Lightburn on a trial license. My computer is an Apple MacBook Pro with an Intel chip and Ventura 13.1. I connected via USB cable and the D1 was not found. I followed some suggestions for a manual install and importing the XTool-D1ProV3.ibdev and the Lightburn acknowledged the parameters, but when I try to send anything to the D1 I get a message about the machine may be busy or paused. When I try to confirm my USB comm port I do not have any listed. The listed ports are cu.usbserial-1410, cu.blth, cu.URT.1, cu.URT.2, and cu.bluetooth-incoming-port. The XTool Creative Space software connects and works fine.

Any suggestions would be appreciated

It’s so nice to get replies and assistance from not only the community but also the software company itself…

No offense, but posting snarky comments certainly won’t help. Your best bet to get fast and accurate support is to e-mail They have dedicated support staff that monitor that e-mail address, and a tracking system to ensure that it gets addressed.

You are very correct and I would like to apologize for my inappropriate comment. I was frustrated and should not have sent anything rather than being offensive.

1 Like

I did some testing yesterday on a couple of MacBook Pros (on Intel one Mac Silicon) both running Ventura 13.1 (not mine). My apologies for the delay. I wouldn’t have been able to offer anything helpful, any sooner.

There’s a screen that Mac throws that encourages users to click ‘ok’ when they install drivers.

You’ll need to click Open System Settings and grant permission for the driver to install.

You’ll need the CH341 Driver offered on the xTool site.

With the Driver installed one of your USB options will have ‘wch’ in the name.

The one other strange point about Mac and Ventura was that even with the correct ‘wch’ port selected it wouldn’t connect. With the port selected, we closed LightBurn and restarted it. It connected immediately to the correct port.

I hope this gets you going and helps the other folks with Ventura 13.1.
13.2 was just released and I’ll likely retest.

I appreciate the advice, I did not see the screen about the extension blocked, but I have purchased the software and I’ll try it again. I did end up installing it on a Windows based machine and everything went fine. I just prefer my Mac