Lightburn does not see my Emblaser 2

I am at my wits end here. I received my Emblaser 2 prior to Christmas and was able to get it to complete the first Focus Calibration on the card. After that nothing. I had Afinia log on to my computer and they could not figure out why lightburn would not see my Emblaser 2 so they had me send it back. They were going to send me another one and I waited and waited. Finally after calling a couple of times they sent it out and now this one is having the same issue.

It sees the camera just fine and sets it up but still does not see the Emblaser 2. I don’t know what to do anymore and I even tried it on another computer and the same thing. Also, changed USB cords and still does not see it.

Any help would be appreciated. I have followed the step in the manual and I just can’t get it to see it even set it up manually. Still nothing.

Have you followed:

What do you mean by “won’t see the Emblaser” - in what way? Have you created the Emblaser device and chosen it, and it’s just not connecting?

Not trying to be pedantic, it’s just not clear from your wording where the problem is, so a little more detail about what steps you did and where you’re stuck would help.

Hi Karen,

If you are using a Windows 7 or 8 machine, you will need to follow these instructions:

Please also insure you are not using any USB hubs or extensions.

To follow on from what @LightBurn asked, when you say ‘the same issue’, do you mean you were able to connect initially?

This guide will help you make sure the Emblaser is set up correctly if required:

  • Lliam

The Emblaser device was already in the Lightburn software. Lightburn cannot find the device and I have created it manually and it still can’t find it.

The problem is it worked for a brief minute initially and then it would not find the device (laser). It does not show up as connected on my computer either. I have purchased a new cord and tried it on my laptop also and nothing.


I would contact Darkly Labs for assistance with this. It sounds like an issue with the machine itself, possibly. Are you running Windows 7? You need a specific driver for that OS, but not for others.

No, I am running Window 10, and I have tried everything. I have never had an issue setting up any machine on my computer. I will contact them tomorrow. But, so far they have not been any help for this situation.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.