LightBurn doesn't connect to my Xtool D1 Pro


A few weeks ago, I downloaded a trial of LightBurn and installed it on my old HP laptop running Linux (Ubuntu 20.04LTS).

It worked nicely, so when my trial expired (yesterday), I installed it on my newer Dell laptop running Ubuntu 23.04 and bought a registration key:

On this new system, I can’t get LightBurn to connect to my Xtool D1 Pro.

Before the install, I added my username to both the dialout and tty groups:

$ grep -Ee 'dialout|tty' /etc/group

And after the install I imported the xTool-D1ProV3.lbdev file:

But when I click the (Choose) dropdown to choose my output port, I am given no choices:

I can’t choose an output port like I did on my old laptop, so I can’t change my status from Disconnected to Ready :frowning:

I’ve tried (on multiple occasions) powering down and restarting my laptop, unplugging and restarting the Xtool, switching to a different USB port on my laptop, and doing all of the above in various combinations, all to no avail.

Does anyone know how I can rectify this situation?

Thank you,

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.