Lightburn doesnt detect 3018 cnc

The ‘origin at front left’ in the Devices window is talking about the physical origin of your machine, IE, where your laser system believes X0, Y0 is.

The Home button you highlighted tells your laser to run its homing cycle (if enabled) to seek out the limit switches that it uses to determine its location. These are often at the origin, but not required to be. The common K40, for example, has the limit switches at the rear-left of the machine, but the origin is front-left. It knows how big the working area is, so after finding the rear-left, it knows “oh - I’m at X0 Y200, so X0 Y0 is 200 mm down”.

The “Go to Origin” and “Set Origin” buttons are referring to the user/job origin, not the machine origin. This is where I meant that the CNC and laser terminology get confusing. The Job Origin / User Origin is where the laser head position is relative to your design when the job starts, and we cover that here:

With your machine at the bottom left, if you type:

G92 X0 Y0

In the console and press enter, it should reset the current position of the machine to 0,0, so the Get Positions button now reports the correct values.

You should also set:


The $10 setting controls the way coordinates are reported by your machine to LightBurn.

Most of these are covered here:


I powered everything up and when I click on Get Position, it tells me x0 y0. The machine is currently at what I believe to be the laser position farthest back left.

So you say enter G92 x0 y0…i got ok. and if i click Get Position I still get 0,0. So im guess the button Get Position on lightburn and g92 x0y0 do the same thing in this case.

You said set $10=0…i got ok again.

So i decided to use the location jog button and click in the center of the canvas…one of the motors made a loud noise, the x axis motor moved to what looks to be the middle, but the y axis motor didnt move at all, i think that was the one making the loud noise.

Without having to click on it, Position seems to be x150 y90. And if I click on Get Position it gives me that same point. But something happened with the y motor.

I went to the individual move buttons and clicked on
X- and got spindle moving left & Get Position is x140 & y90
X+ back to x150 and y90
Y- bed moved towards me x150 & y80
Y+ bed moved back into place, x150 y80.

Clicked on Canvas 40,40 and the laser is now pointing at back left corner almost, Get Position 40,40

Clicked on Canvas 140,40 and the bed ran over the limit…so i have an issue with the y axis still. The Get Position reads x40, y140.

$$ gives me $130=180 & $131=300.

Clicked on Canvas 40,40 and it moved to the back left again and Get Position is 40,40.

Clicked on Canvas 40,240 and it moved across to the right side, Get Position x240, 40.

Clicked on Canvas 240,100 and it moved backwards w/o overrun, Get Position x240, y101.

So Im guessing I need to reset my 0,0 closer to the edge of the platform? I just eye-balled it the first time plus a few mms for caution.

How should I make sure where I want to set 0,0 as machine origin is exactly the corner of my platform?

I decided to type G0 x0 y0 as the doc referenced above says…and it went to the back left, but it doesnt seem to be where I set it. Oh, how do I turn on the laser from lightburn? I didnt find it in those docs. I mean turn it on but just a bit so i can see where on the platform its actually pointing at.

At present, after g0x0y0, it moved to what looks about 10mm from the left edge and 30mm from the back edge.

Ive modified my $30=255, and the S value in Device Settings to 255 as well and activated the Enable Fire button which i found in a video was used for positioning the laser. Its supposed to activate a button no the panels in lightburn for activating the laser but I dont see it happen, i dont see the button.

Here is my





































For the Fire Laser button you need to enable the switch, then quit and restart. The button will show up in the Move panel in LightBurn.

Ok I did and I get the button, I set it to 1% and 4% but when I hit fire nothing happens. The button lights blue but the laser doesnt light.

G92 X0 Y0 tells your laser “Where you are right now is X0 Y0” - if you jog the laser somewhere, like the front left for example, and enter that command, that will become the new X0 Y0.

To use the Click to Jog button, your laser needs to use positive coordinates to jog into the work area, and the origin has to match the corner you’ve told LightBurn your origin is. If either of those isn’t true, it won’t work, and lots of CNC systems, including the 3018, use negative workspace values for some weird historic reason, where dedicated laser systems don’t.

For turning on the laser to see where it’s positioned, go the Edit > Device Settings, and enable the Laser Fire button, shown here:

Restart LightBurn, and in the Move window you’ll see a button with a power value that lets you turn on the beam:


What % is safe to turn on and see it in order to align?

OK I tried and 20% is as high as it goes and still no laser. :confounded:

I got it!!!

Why didn’t anyone tell me the laser has a small button up top which turns it on?! When I plugged in the controller I heard the laser fan turn on so I figured the actual laser was also on. But no, I had to press the button FOOL!

1 Like

Hey, @marciokoko…Press the button fool! :wink:

Seriously, glad to hear you got sorted.

1 Like

Press the Damn button you fool! I think it’s from Innerspace! :rofl:

Thanks guys

Oh OK wait I forgot what I was doing. So I turned it on but couldn’t get a picture of it so I marked in pencil on this envelope I have over the platform. That’s whereabouts the laser hit.

Lightburn has its machine origin set at 0,0 where that pencil dot is on the envelope. It’s clearly not at the corner of the platform but rather about 10mm off the left edge and 30mm off the back edge.

Should I make the laser point at the very back corner and set THAT “corner” as the machine origin?

BTW I just made a run for a square i drew and set it to 50% power but it didnt do anything to the envelope, why? The machine worked as expected but the laser didnt burn.


Now I’m gonna do 2 things:

  1. Review the whole deal of machine and job origin to figure out what the big deal was.

  2. Make a video for my channel explaining how I got it set up!

Thanks guys

Ps…next I have to get the cnc milling part of it working :roll_eyes:. I can still use lightburn right?

LightBurn is for Laser control. Don’t have it running at the same time you are using your CNC software.

One more question…I did make those changes I saw in a video of setting the SvalueMax to 255 and $30=255. Is this normal?

Because I remember that when I ran the cut at 700mm/min and 60% power, it didnt do anything to the paper, but when I ran it 700mm/min and 70% power it cut the paper.

But I also made the change of the cable as I mentioned. So I dont know if it was maybe just the fact that I upped the power from 60 to 70% that made the laser actually cut.

I would recommend you do three things:

  1. spend $5 on some limit switches and wire them in.

2 for X&Y, 2 for Z.

The following is from the official Grbl GitHub documentation repository (I shared this link above) where you will find very helpful information as you try to understand your new setup.

When using the Laser Mode of grbl ($32=1), the $30 and $31 settings are used to control the power of your laser. Some manufacturers will pre-set the firmware they ship, having $30=255. This is fine. The official setting, as you can see below, is set $30=1000. This provides a larger set of values one can use and as such, provide finer power control.

$30=1000. Max spindle speed, RPM
$31=0. Min spindle speed, RPM

The key issue is you must match your firmware setting and the ‘S-value max’ in LightBurn.
LightBurn and Grbl’s default setting is $30=1000. But what you have is fine.

I have these but without the metal strip, just the black button on the body of the switch.


Another question, is the controller supposed to make a bunch of funky noises, like those old movies where computers are performing some complicated task and they beep and bop a lot? Because I just made my first burn and it sure made lots of beeps and bops.

and the result looks like this:

Both job origin and machine origin are bottom left.

OK I redid it because I had switched my origin the night before :rofl:

I’m guessing I lowered the power too much?