Lightburn doesn't know when Ruida is full

My laser (with a Ruida RDC644XG controller) seems to have a limit of 99 files.

When it’s full, if I send a file over the network from Lightburn, Lightburn thinks it has succeeded but the file is not present on the laser, and when I press the go button it just cuts the previous job.

(1) Is this fixable ? Feels like it might be a bug.

(2) Is there something smarter I might do about it than periodically deleting lots of files from the laser ?


Like your computer it can only hold so much. You can always upload the ‘deleted’ file again. You can delete and manage these files via Lightburn. Deleting from the front panel can also be done.

Ta - my point is not that the machine fills up, but that Lightburn doesn’t know (and so doesn’t tell me) that the upload has failed, which tends to result in me repeating the previous file by accident.

I have never had a failure that Lightburn did not inform me about. Of course, I don’t let my controller fill up either. As a result I’ve never tried to ship a file over there when it was full. I would think something in the route would return an error and lightburn would tell you.

You must just send it and use it, because it would take forever to find a file from the front panel. I’m thinking the only reason you’d leave them there is so you can use them again. I run an Ethernet connection.

You can pull up the files list and delete any or all from Lightburn or the control panel.

Yes, you’d think it would tell you, but it doesn’t. That’s my point. I’m trying to report a bug here.

I think they know

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.