Lightburn don't find and connect with my laser

Lightburn can’t conect with my laser, it’s a Boye Laser c-1008 CO2.
This Laser on link Product

Just run with the original software.

LightBurnLog.txt (8,2,KB)

May anyone help us?

It seems you’re trying to connect through USB. Can you confirm?

Also, I assume you are using RDWorks today. Please also confirm.

Can you take a screenshot of what you’re seeing in LightBurn?

Welcome and thank you for your question and link.

Speaking with the team here and reviewing a few images we found, we are unfamiliar with BOYE LASER APPLIED TECHNOLOGY CO., LTD. and have not previously seen the particular control panels shared in those images.

What is the name of this software? Looking at the site you shared, I see LaserCA as a software title, but not much more listed specifically on the motion control system used.

If you have further details, please share.

All this to say, in all likelihood, LightBurn does not currently support this laser setup.

To me this looks like a rebranded Ruida 6442 going off of the model number and labeling on the controller.

Open to learning… :slight_smile:

1 Like

The Moons’ SR looks like a lot of pins for a typical stepper motor controller.

I think I found the manual for this part of it.

yes, its connect through USB.

This is the software download

  • Just a friendly reminder to not post passwords or private or valued information on a public forum. (edit by @johnjohn)

New sowftware link: download
Its the LaserCA4.3.4.3

  • later software link moved from late post. (edit by @johnjohn)

Photos of the machine

Original Software:

What I see in lightburn:

When I turn on the Laser, shows ready in lightburn, when its on CanCan config.
but any comand works. In the console looks waiting conection. When I try Ruida, just appears disconected.

I forgot any information?


When you posted 5 back-to-back posts with links and images our automated security settings flagged these as spam. I have allowed them.

We welcome your enthusiasm.

I took some time to clean these up and I have improved your standing with the automation so future problems should not occur with multiple posts.

1 Like

CanCam is a GCode device. Your engraver is not this.
‘Ready’ means that LightBurn is ready. ‘Waiting for connection’ is the message that your engraver is not yet connected.

It appears that you have connected with the Original Software. Please close it, and be certain it is closed with Windows Task Manager. After you are certain it is closed Launch LightBurn and open the Console window and Laser window as you have done here:

Your computer communicates with the engraver so we can confirm that the driver is installed.
We may need to select the correct COM port.

LightBurn 1.4.00 may find the Ruida controller automatically.
Wait 10 seconds for a message in the Console window.

In the Laser window…
In the laser window, click the Devices button in the bottom row on the Left. Manually create a Ruida device. Do not worry about the origin position or the size of the bed. You may pick nonsense for these numbers, just complete the Device Profile.

With your Ruida device profile selected in the Laser window, watch the Console Window for the connection message. It may simply connect.

Wait 10 seconds again.

If no message is seen in the Console window, we select a new COM port based on which options are available to us in the Laser window. Click the middle button in the bottom row of the Laser window. If you are presented with a new option for communication, and if LightBurn hasn’t connected yet please select the different or new option.

Wait 10 seconds again.

Continue to select new options for the COM port until it is found.

Once you connect, click Edit, click Machine Settings, click the low button on the right hand side of this window that says ‘Read’. This will read all the setting from the controller into LightBurn.

Please let us know if this connects and works for you.

My earlier suspicion that the controller was a rebranded Ruida is in doubt with these latest photos. Perhaps a bootleg or licensed edition. The panel screen contents look the part but the panel itself looks alien although the buttons all match one-to-one with a 6442 panel.

LaserCA, however, doesn’t look familiar.

So it’s possible or likely that @Rick’s original assessment is correct here and that this may not be supported in LightBurn. Though I suspect it wouldn’t take much to enable it if it indeed is based on a 6442.

1 Like

I’d plug it into the lan, Ethernet connection… At least that’s standard…

Most of the world doesn’t support hacked and resold copies of our products being sold under different names… I doubt China does so either… in all likelihood, it’s custom made at the Ruida plant for the vendor…

Ethernet would be the best way to see if you can talk to it… We know the Gweike lasers have custom software for their machine… also a Ruida…


First, thanks enverybody for the help.

I will try what John recomended and conecting lan too.

I got some informations from the original software.
I saw this archives (.upd) on the paste of the software. by644xg. (maybe a copy of ruida 6442.

Here’s the files of the software, fi someone can read the codes. Laser CA firmware

1 Like

The link provided is not public, so cannot gain access until you do a thing to make it so. :slight_smile:

Sorry Rick, try again.

@danmariano, No worries, I’m in now. Thanks.

Looking into that zip file, I do see a file called “RDCAM.dll” which is similar to the Ruida software naming, so we may have good news. At least we have another test for you to try. :slight_smile:

When you installed LightBurn, did you also install the FTDI driver found on the last page of the installation? If not, please run again, advance to that last page and click the check-box and continue. This will install the USB driver needed to communicate with the control board.

Once complete, try the ‘Find my Laser’ process again, as John describes. If this is successful, you should be presented with the beginnings of a new ‘Device Profile’ for a Ruida system setup.

Please let us know how you progress.

Yes, I install the FTDI, but nothing on ‘find my laser’.

Thank you for this update. The next step to try would be to build a device profile manually. Below, I provide the steps to take so. When walking through this process, select ‘Ruida’, USB connection and choose back right as the origin.

Please update as you can. :slight_smile: