Lightburn For Galvo Rotary

I just started using lightburn for galvo and I am having an issue with my rotary. It works and spins fine for the first tumbler that I engrave, but when I swap out for the next one, it runs very slow. It triples the total run time.

The best way I can describe what it is doing is running a line, pausing for a brief second, and then running the next line. The quality is fine, its just the speed.

I was thinking it was maybe memory, but the computer I am running has 16gb ram and it is only using about 8 of it. I already ordered 32gb that will be here tomorrow. CPU usage is around 4%. It is an HP Elite Desk 800 running windows 10 64bit.

I tried all of the normal things like restarting the computer, checking all of my settings to make sure they look right, kicking it, etc.

So far, everything else I have done on Lightburn has been great, but for anything rotary I am having to go back to Ezcad, which is well, Ezcad… Any help would be appreciated.


I just got the notice for the update so I installed it to see if maybe something on the new update would fix this and something is definitely not right with the update.

When I have rotary enabled, it fires the laser very far down on my workspace. Almost like it thinks center is at the bottom of my workspace.

Mine did the same thing, it would start off fine then speed would drop to a crawl. After a bit it would speed up for a few seconds, then drop back down. Started while using the rotary, then went to do some photo testing and same thing. Did all of the normal resets and nothing fixed it. It was hardly using any system resources, just started lagging like crazy at random.Went back a couple days later to play around and it all started working fine, no updates or anything … I posted it on the forums and no one commented.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.