Lightburn Galvo - latest version laser random disconnects

Used EZCad for year before Lightburn, and ezcad would crash or mess up every day. I switched to lightburn a year ago and the first year was great. Maybe a lockup / crash once a month, not every day!

Then I got a message about a new version 1.4. So I updated, when I installed I screwed up and reinstalled the galvo drivers. When it opened, I realized my year license was over, so I purchased another year. Put in my license and it was working fine.

About an hour later… it started acting up… For example I would close the framing window and it will stay framing. Eventually I realized the laser was disconnecting.

When it comes up disconnected in lightburn, it isn’t disconnected in the hardware management. It still shows up properly. When it disconnects about 1/2 the time Lightburn comes up and says “lightburn has crashed” and the other times I can just turn off my fiber laser and turn it back on. When I turn it off the windows chimes to let me know a USB has disconnected. Then I turn it on, windows chimes to let me know a USB has been connected and it often starts working then.

I updated to 1.4.01 first thing this morning I checked and I was on the latest version.

I went though some of the other posts about usb disconnects. I don’t believe it’s a sleep/inactivity issue, but cause my PC is set to always on. I have shut down the PC several times since then. I have a job to do today and it’s very frustrating crashing very often, every 3 or 4 runs. Nothing has changed with the PC recently, other than the software version. I replaced the USB cable as well as the PC port.

If anyone has any suggestions, I’d love to hear them.

I am aware it could be the laser, I know it has to die sometime. Worked so well with light burn for the first year and now this, just had me thinking it was a software/driver version issue or something with the updated license? Maybe I can go back to 1.3 to see if it behaves better with that version of software and driver.


The actual meaning is “sleep due to inactivity”. Has nothing to do with PC staying on.

This is worth a try. I have heard of cases with the Ruida that this made a difference, likely due to a Windows update. I think @jkwilborn is well versed on these controllers. Maybe he can help.

Thanks, MikeyH!

Ya, I will look into the sleep issue more, I may have disregarded that prematurely. It’s just odd, cause it may work for an hour, then fail 3 or 4 times with just a 5min run between them. I’ll bet if it was just on the run screen it would be ok. Seems like when I am closing the framing window it fails, or opening the framing window it fails… but I could be wrong on that.

Windows update is something I didn’t consider… I remember that machine restarting several times because of updates in that timeframe. So there definitely could have been an update right when it started acting up. I wonder if there could be something I could roll-back to get it running smoothly again.

Thanks for the input!

Just to add some more info.

I updated the power options.

It always seems to crash on the opening or closing of the framing window. I changed things up so I wouldn’t have to do that on this job. However it’s still crashing. Might run a few times then ‘disconnected’

I found that if I go to the hardware management and delete the device and then scan for changes it pops back up in lightburn.

Trying to find a workaround without having to turn the machine off and on, which can’t be good on it…

Any other options to try? Any guesses on windows updates to rollback or anything I can do to get my stable machine running? Am I the only one having this issue? Maybe my device is just acting up.

I checked into any power disruptions and nothing’s changed in several months. No new equipment running or anything…

update: My little remove device trick isn’t working - it worked once… haha

I changed out the ‘usb extension cable’ before. The one going from the back panel to the PC. Right now I opened up the unit and found the BJJCZ card plugged a new USB cable from that board directly to my PC. The cable that was going from BJJCZ card looked pretty nice ‘gold plated’ :slight_smile: but now it’s got a new cable from the board to the back of my PC. I have tried different slots and front of PC BTW.

Fools gold :face_with_spiral_eyes:

Just kidding … I tried but my resistance was futile

This seems to indicate it’s an OS problem. Lightburn doesn’t manipulate the usb port hardware directly, it all goes through the OS. Actually from the OS → Device driver…

I run Ubuntu, so most of it’s drivers just work and there isn’t any drivers to find, they are with the machine. Worst case you have to install them, a one line command…

I have the same board I think on my fiber. It stays connected most of the time and is much more dependable than the Ruida usb. I’ve never lost a job from a disconnection, yet.

My only issue has been that the usb on the fiber feels mechanically lose. It’s still under warranty, so I’m not cracking the case unless Cloud Ray advises me otherwise or the warranty lapses. A few times, I crawled under the table and plugged it back in, it fixed the issue…

The comment on reinstalling the driver seems pretty clear evidence that the issue is occurring within the driver module and is not Lightburn related.

The os can set timeouts for the port, limit current and a surprising number of strange things. When you reload everything, it operates… This also pretty much eliminates the hardware such as the cable…

Wish I had a good fix for you, sorry… have you tried running it on some type of Linux variant?


Thanks jkwilborn! I appreciate ythe input and BORG reference. :slight_smile:

That whole remove the device and re-scan worked once, but hasn’t been worked since, so still not exactly sure where the issue is. I am doubtful it’s the hardware, but it certainly could be. It has to fail at some point I suppose. Our brains go towards what changed as the culprit, worked good for almost a year with no disconnects… Then on the day I update to 1.4, have license issue, and reinstall the drivers it starts acting up. I understand that it could be coincidental… other issues are harder to see past the coincidental ones.

I only had 9 to run today after my usb cable change and it didn’t misbehave.

I usually go a week or 2 between jobs, still trying to build up some customers and get the fiber in more use. If it fails again, I’ll probably try a new PC, see if that helps out… I run my CO2 connected via ethernet and my FIBER connected via USB off the same PC and I have been meaning to connect a PC to each laser so I could run them both at the same time if needed.

Only other thing I have done in recent month which I didn’t think about this… I tried to install a camera for my CO2 which I bought from lightburn. It worked for a day, then failed. So I disconnected it and haven’t got back to it. I wonder if it caused a hardware or driver issue that is messing with me. Although, I have had many jobs after I attempted that camera and they worked fine…

If you think it’s the version, which I don’t think so, but I’d suggest you eliminate the doubt and install one of the previous release versions from the repository

I run both the beta and release, on my single Ubuntu machine. I’d assume you could do the same on yours?

It should be an easy check to run the previous release and see if it misbehaves…


Thanks Jack,

I thought it was the version at first, because it happened right after I upgraded. Obviously if nobody else is having issues then it’s not that. I can try an older version too… actually I did, but then I tried to open up my 1.4.01 saved file on 1.3 and it didn’t open properly, so I got scared, went back to 1.4.01 to finish out the 9 basketballs I had left.

Only thing that made me think it was software not hardware is that the device still always showed connected. When I turned off the laser the device would be removed in device manager. Windows would give me the ‘usb diconnected’ sound. I am guessing lightspeed’s connection to the device is much more sensitive. It can detect a miscommunication and disconnect when windows doesn’t.

Maybe the rewired USB will fix it… if not, I’ll try the older version 1.3 to see if that help… if that doesn’t do it then I’ll try a new PC… if that doesn’t maybe I’ll try a new BJJCZ board… if that doesn’t work, then I’ll give up… haha

I read on the forum about electrical issues, which nothing has changed. When I first setup the laser, it had a grounding cable which I actually wired to ground. Not sure what I can check for an electrical issue… anyone know anyway to check for issues? My voltage is coming in within range and wired properly.

Thanks again for the help and I’ll report back after next job.

FYI - had a small job and still had issues disconnecting - I will go back to version 1.3 next to see if that helps.

Thanks for letting us know… I not sure what to suggest… I really wish they had implemented Ethernet on these…

If you have success with an older version you need to let us know…

We’ll be watching…

Good luck


So this is interesting… I went back to 1.3 then I opened a shape - hit frame then escape key - repeated that 50 times…

I went to 1.4.01 - I meant to install to a separate directory, but it just kind of installs over older version - anyway, I did the same file / escape key / rep
eated and it got to exactly 20, before:

it disconnected. I will repeat the test because it could just be random, but it’s interesting.

I think maybe we should get @JohnJohn to help out here…

Maybe he can suggest something that will help resolve this.


1 Like

Well I thought 1.3 was invincible but I got a disconnect twice on 1.3 yesterday. So there goes that idea… both times I was just adjusting the framed vector left and right and then all of a sudden disconnected.

So what I’ve tried:

1.4.01 installed
reverted to 1.3
EZCAD card was connected to a usb extension - then usb cable. Ran a good USB cable from PC directly to EZCAD card.
Windows 10 updated - latest updates
Altered USB power settings
Keyboard/Mouse/FiberLaser only things plugged in via USB

I am going to try a new PC next, unless someone has any other ideas.
I thought about buying and installing an aftermarket USB board to connect only to the fiber laser.

Seems like the connection between my PC and USB has sometimes a bit of latency that causes lightburn to show disconnected. Can you increase the timeout or anything on that? I don’t have anything else running on that PC… just lightburn.

I apologize for the updates - if anyone has the same issue, figured this might help :slight_smile:

I saw they had 1.4.03 out… didn’t take too long to disconnect.

I just frame the design and move it around up-down-left-right arrows and I can get it to crash pretty reliably. :slight_smile:

uninstalled - went back to 1.2.01
I could not get this version to disconnect - if it did disconnect, it came back! It would disconnect for a split second then start showing connected again… odd.

installed 1.3.01
same behavior - I can get it to disconnect, but a second or two later and it re-connects.

installed 1.4.03
same behavior - I can get it to disconnect, but a second or two later and it re-connects.

I will try it like this on the next job, see if it behaves. It looks like I somehow lost my ability to reconnect after a disconnect, but now it’s behaving? I will keep this thread posted. thanks

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.