Lightburn ignores letter spacing from SVG

Hello folks,

I have a question. Normally, I edit in INKSCAPE my files, but I’ve noticed when I import these SVGs to lightburn, it works as expected except the letter spacing. Let me put an example:

Black path is from lightburn, and red one is imported from inkscape, as you can see, lightburn detects well not only the text size but also the font family.

The problem is that it’s ignoring the letter-spacing (h-space in lightburn), so the object is a little bit different:

I know I can select all and setup h-space manually in lightburn, but each font has a different h-space.

The question is: Is there any way to achieve this? Maybe something I can include in the SVG? Like a command?

Regards and thanks you for this really nice software :slight_smile:

Have you setup your input for Inkscape?

Don’t know if this has an effect or not on your issue.


@jkwilborn that setting wouldn’t affect what the OP is seeing.

@sergiocasero until @lightburn can update the h-spacing in LB, you can select all of your text and Path>Object to Path, and save another SVG with something like LB after your filename - like FilenameLB.SVG

Object to Path removes the text data in Inkscape, so the “text” becomes shapes with fills. That is why you create a separate SVG for Lightburn, so you can go back and edit your original file if you need to.

@jkwilborn I’ve tried with no success :frowning:

@RalphU thanks, I was thinking exactly that but I can’t convert them to path since I need to “weld” the texts too, and a path can’t be “welded” :confused:.

So now I have manually to:

  1. Set the h-space
  2. Enable “welded”

My intention is to automatize this process as much as I can since my plan is to hire another people to do these things, and I want to avoid errors…

You might want to consider the program for manipulating connected text. They have connected text modifiers, so you just key in the word and it connects it and welds it. Then you can copy and paste between Cuttle and Lightburn.

Untitled Project - Component A (14)

I’ll check it thanks!

1 Like

I’ve added support for the Letter Spacing property for a future release (likely 1.7). It’s not perfect, because InkScape handles the spacing a little differently than we do, but it’s as close as I could make it.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.