Lightburn is flipping my images

I have read the help on similar issues, my origin is the same for the Acorn controller on my mill and in light burn. The issue is that the Acorn Controller homes at right front. Thus it sees all movement of the workpiece as a negative X movement. I can see no way within Lightburn to have a similar axis. When I created the gcode, the image exceeded allowable travel in the x direction, when I changed all values on x to negative I got a flipped image.

We have a section of the documentation to help. This is worth review, Common Grbl Setups - LightBurn Software Documentation :slight_smile:

You have two machines with different 'home’s I think you will have to manually flip it to correct the image, if going from one to the other. Generally you don’t get to pick your ‘home’, which is what it sounds like you’re trying to do…

Good luck

:smile_cat:

Home and origin are not necessarily the same. Can you confirm that the Acorn is a GRBL based controller?

If so, can you provide the following?

  1. Screenshot of Device Settings
  2. XY Coordinates for each extreme corner of the machine
  3. Please run a homing operation and then run these commands in Console and return results:
$I
$$
$#
?

Had a senior moment for the last day and a half leading up to this post. With Fusion 360 I create a model relative to my design origin then after posting the code, I go into my CAM software and setup my work place home. When I made the design in Lightburn the design process was enough different that I did a memory reset on how to handle it. After looking at my product this afternoon I realized I had not set a workplace home and once I did that all my problems (at least relative to flipped images) went away. Now if I could only find a fix for my topping the ball in my fairway shots.

1 Like

That’s not what I was expecting but glad you got it.

As for your fairway shots, make sure you’re keeping your head down all the way through the point of contact. :wink: