Lightburn is resizing SVG Files? Is there a fix?

Hi all, I’ve been buying Cutting files from Etsy sellers and I’m finding that SVG files are reducing sizes when I drop them into Lightburn. For example for a wall mounted item that is to be cut with 3mm wood, the tabs are reducing to 2mm?
A seller sent me a PDF file of the same item and it worked, all 3mm in size? Sadly many sellers don’t offer PDF’s in their electronic items they sell, mostly SVG, DXF etc. Any thoughts here how I can fix this?
I have Inkscape but don’t know much about it to understand how to fix SVG files to stop lightburn from dropping the sizes?

Appreciate the help all.

What do you have set in the LightBurn Machine Settings for ‘SVG Import Settings’? And, what DPI is used in this “Etsy sellers” original content?

Hi Rick, thanks for the reply. My settings are defaulted at 96dpi. How would I tell what the dpi settings are on one of the files I purchased? the site I bought it from doesn’t mention that? Curious if there is a way?

I did ask one of my sellers what DPI they are creating the files at. Hoping I hear back.

Rick heard back that one seller doesn’t use Inkscape they use illustrator. Maybe that’s the issue?

Update I tested this and it worked!!!

Changing the lightburn settings to illustrator set the file correctly. Bingo! I just have to remember to change it back and forth and keep an eye on files I’m loading. Thanks Rick!

1 Like

It’s a bug in Illustrator - They should be saving files in real units, like mm, but they don’t, and the SVG spec isn’t 100% clear on what size things should be if it’s not specified. If the designer can send you an AI file, that will work fine for LightBurn, and won’t have the sizing issue, but there’s no harm in just flipping the setting and reloading if you need to.

1 Like

Thanks Oz. would I leave my import settings at SVG or Illustrator for the AI files?

For the AI files it doesn’t matter - they don’t use that SVG DPI setting at all.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.