Lightburn jerky and stutters when engraving raster image

I have tried several ways to figure this out so i will try and explain the best i can.
Import image into image-r.
Make sure resolution is 300dpi and that its the size i need.
Set material to Norton Glass. as well tried greyscale
Save as jpg, as well tried png.

Open in lightburn. Set speed and power. Turn on passthrough so that it uses the image-r norton glass settings. Press start.

Now it may start off fine or it may not it acts like it jumpy and stuttering when going over certain area looks more likw gradient white/black area but its really jerky.

So i try it all over again this time i turn off pass through and i select jarvis but i still get the same results just not in the exact same areas.

It doesnt do this when i am engraving any lines or text or any vector files. Only happens when i engrave raster images.

I have also tried from 100mms to 70mms to 50mms to 25mms with the same jerky results

Fast white space is on at 50mms if that matters.

Any thought or ideas would be greatly appreciates.

Also int he preview i see nothing there that would cause this or see why it is doing it.

Link to the lightburn file if that helps

And how does it (your laser) work with other software?

Never used it with any other software.

So i use the factory laserbox software using the same exact file and speed i tried in lightburn it engraves flawless.

Not certain but 2 things come to mind:

  1. Are you using the latest firmware for the machine? You mentioned not using the native software.
  2. It looks like the laser might be under running its buffer. Try a test run with a dramatically lower DPI, like 10 DPI. If that works, then you know it’s something related to this. Looks like Laserbox defaults to equivalent of 254 DPI so not sure if you changed that to 300 DPI to match your LightBurn file in your test. Another thing to look at is what are your connection settings in Device Settings?

Firmware is up to date.
So the way the driver in this laser works is it actually loads the whole file the board and processes it from there. Now not saying this is the issue but i have cut several vector graphics that have doubled the cut paths and engrave paths . This image was 8x10 the last multi vector was 18x16.

I changed lightburn to match the image R file of 300dpi as thats what i designed it in. Also when i opened the image file itself i then matched the 300 dpi.
As a test before i went to bed i tried 254 dpi and same issue. I wouldnt think it would be a buffer issue as when i use the exact same file from laserbox ( the oem software) it engraved the same file amazing but at a 11x17 image size. This was also maxing out the resolution and LPI or in the software LPCM

As far as device setting it uses a pre configured file you import to set up the laser for lightburn. I also tried redownloading that file and importing it again but same outcome.

I will try the really low dpi and see what happens.

So you’re saying that LightBurn streams the entire file to the laser, the laser reports OK, and only then proceeds to start the job? So does that mean that LightBurn believes the job is done almost instantly, or at least as soon as the job is finished sending?

If so, then most likely a bug in the GRBL firmware implementation since LightBurn is out of the picture at that point. Could also be a bug in g-code generation but highly doubt that in this case.

This rules out any base difference with Laserbox defaults.

Yeah. Wasn’t sure if you had changed the default in Laserbox or not.

If the entire job is fully buffered before starting then this isn’t going to be the issue.

I hadn’t heard of people having image issues with D1 though. Certainly other issues but I don’t recall issues with images so have to think something else at play. Hopefully someone with a D1 who does this sort of thing can speak up.

Do you mean mm/second or mm/minute?
It’s very easy to mix this up and have a hard time. I sure did.

It’s also easy to overlook the unit change when switching software.

If you have commanded the engraver to travel faster than it’s maximum rate (in mm/second) setting in firmware it will perform in seemingly erratic ways.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.