Lightburn keep crashing when offsetting a complex file

The program keep crashing after I use Offset Shapes tool.
I must admit the vector graphic is quite complicated but not that much to crush the program. I tried with several different ones from ai file I got them. I bought the file in one of online font and graphic shops. It contains hand drawn pictures of animals, done on tablet as author says. Anyway some of them get offset done quite quick with no issues, but about 7 out of 10 not. It is worrying for me as this graphics had to be engraved on my stuff I prepared some time ago. Now it is time zero to produce end product and well I can not proceed.
Any idea how to deal with it?
Regards
Lukasz

Thank you for reporting this. LightBurn should not crash. Do you get a report when this happens? Please share all crash reports via email to support at lightburnsoftware dot com, include the file that you are having this issue and the link to this post, so we can take a look.

Are you using 64 bit or 32 bit LightBurn? Can you send us the file, so we can try to reproduce the issue here? (Email it to support@lightburnsoftware.com with a link to this thread)

sure I will. no problem… are the reports saved somewhere in program? alternatively I can do printscreen

I can not find if it is 64 or 32 but assuming it was downloaded from your website and my win7 is 64 bit then it more than likely install for me right version

I’ve just sent email to you…
I am going to sleep now, it is nearly 3am UK time and good to go.
Will check more in the morning. Thanks guys for help.
Regards
Lukasz

pics

its full version now what I am glad but shame it crash…

Why do you need to offset all of the shapes in this file? Why not just offset the outline?

Edit: Never mind - this file has no “outline” it’s like someone took a dithered image and vector traced it.

1 Like

I’ve figured out why this is crashing, and it’s a bit bizarre. Because the offset takes so long to compute, it brings up a progress bar. The progress bar being shown causes system events to be handled, and one of those events is “a number changed” which triggers a rebuild of the offset, while it’s in the middle of computing the previous one. This does not go well. :slight_smile:

Thankfully once I understood what was happening, it was easy to fix.

1 Like

I’m taking the unusual step of overwriting the public release - 0.9.19 now contains a fix for this crash. Re-download from the download page and install over the version you have. Since this is the only thing that has changed, and it’s a small fix, it’s safe.

That is right, I tried to ungroup selection till last possible one but it turns that part of image was selected outline with inside parts of image. That did not help. Image itself is well detailed and it is on plus so someone did great job drawing this, but did not probably thought of other possibilities in use of image so no outline there.
I have found that when it is outlined it speeds up template engraving than the whole image. It is obvious but with images that has outline, not in this time.
Now I have done it for all pictures in group and SUPER it works :slight_smile:

Thank you guys for your hard work in finding the problem and solving it. I am so much impressed that you found the issue so quickly and sorted it. I am amazed with your work and program itself. I am quite new in lasers but Lightburn is one of the best graphic program I ever used and far easier to use than Inkscape. Very happy to use it and support is Top Notch. Cheers guys. Thanks for it.

1 Like