Lightburn keeps getting stuck on "busy" but is not firing or streaming correctly

Hello I have been having issues with my Windows 10 staying connected to my Atomstack X30. I will be working on a project and start it and it will all of the sudden stop running.

There isn’t an error and the console still thinks it is streaming and working. But when I click on machine settings I get the ‘communication with controller failed’ so I can’t see the settings.
I have replaced the USB cable, reinstalled the previous version of Lightburn as well as the driver, disabled sleep and actually reset my entire computer and it is still happening. Can someone please help me. :pray:

Check the power supply to laser for bad connection. You don’t say how you get it to work again. I have had the same condition with my system but my problem is operator error ( I hit the e-stop.) When I restart laser, lightburn says busy and no matter what I try I have to restart lightburn to get it to reset

Yes I’ve checked the power too but it keeps happening. That is what is happening to me too and when I have to reset it it makes me shut the whole program down too.
The last time I got it to work again by reinstalling everything and downgrading to the 1.5.06 Lightburn version but now its happening again and I REALLY don’t want to have to reinstall everything every time to get it working so I am hoping they can help me.

This is usually a bad USB connection. Try another cable and also different ports etc. Use a cable as short as possible.

I have seen this problem several times, the power bricks are suseptible to temperature variations, problems usually occur when it gets too hot or cold, output voltage drops to low enough to drive the laser BUT not enough to Fire it.

I bought a brand new cable and it worked last night for a minute and now stops and is doing the same thing. Connects briefly through the COM port but then there is no machine settings and doesn’t move.

I brought it in doors and it is still not connecting to Lightburn and just looks like it is connected but nothing happens and no movement or machine settings come up.

Try other USB cables. Remove electrical disturbances. You can also try to install a different CH340 driver, sometimes this helps as well.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.