Lightburn locks up when trying to import jpeg

Running 1.0.4 (I think) suddenly became unable to import images without the file dialogue freezing, downgraded to 1.0.0 and issue still persists - any ideas please ?

Do you have antivirus software running? LightBurn launches a helper app to bring up the file open dialog, and this helper could be mistaken for us trying to do something shady. Some antivirus software or system policies prevent apps from doing this, but it’s done to prevent crashes in poorly written preview utilities from bringing LightBurn down with it.

LBFileDialog.exe is a small helper app, and its whole job is just opening the standard Windows dialog to open a file. We do it this way in case you have a thumbnail previewer installed that crashes or locks it, so it doesn’t kill the entire app, causing lost data.

If you rename that to something like “LBFileDialog.exe.bak” so LightBurn can’t find it, it will fall back to using the internal Open dialog, and that will work. :slight_smile:

I do have antivirus but temp disabled it with same issue, also renamed file and now I get this. Everything worked perfectly up untill yesterday and has done for a couple of years

What changed yesterday between the last time it worked and when it stopped working?

To my knowledge absolutely nothing.

Certainly have - I can access those normally with no issues.

I would create a new directory and put a few pictures in it to try. I’m thinking maybe too many files in current directory.

I can import from any other folder so im moving all my downloads to a backup and will try again, 1200 files 28 gig.

Yep that sorted it - all good now :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.