Lightburn MacOS Monterey

I’ve been successfully running Lightburn on a 13" M1 MacBook Pro. I just upgraded to a 14" MBP running Monterey, and Lightburn immediately crashes on launch. I’d copied over my old machine via Migration Assistant, and when Lighburn wouldn’t launch, I grabbed a fresh copy of 1.0.0.4, which does the same thing.

The crash report reads (in part) -

Exception Type: EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000001, 0x00007ff7ffc73af0
Exception Note: EXC_CORPSE_NOTIFY
Termination Reason: SIGNAL 5 Trace/BPT trap: 5
Terminating Process: exc handler [31174]

Triggered by Thread: 0

Application Specific Information:
assertion failed [header->version <= kProjectSourceVersion]: runtime library is newer than runtime
(Library.cpp:99 init)

Any ideas on how to get this going? Thanks!

I just upgraded my 16" Macbook Pro 2019 to Monterrey, and Lightburn seems to run fine on my machine.

1 Like

I just double-checked and my 13" M1 (which I had to bump to Monterey to do Migration Assistant) seems to work okay as well; not sure why the 14" M1 Max isn’t working…

me neither but My Mac Guru has told me not to go to Monterey yet from Big Sur as there have been a lot of issues with Macs not working. Mine is the latest M1 chip 2021 MBP came with Big Sur , should be ok but Im holding off for the moment.

Figured it out. It appears to be an issue with Rosetta not being set up correctly after using Migration Assistant. Going to Terminal and running

/usr/sbin/softwareupdate --install-rosetta --agree-to-license/usr/sbin/softwareupdate --install-rosetta --agree-to-license

Seems to clear up the issue (for this and other software running under Rosetta emulation). I found this via this Reddit post - https://www.reddit.com/r/MacOSBeta/comments/o9gnjo/downgrading_macos_monterey_to_big_sur/

Hope this helps anyone else with this problem.

2 Likes

Hi, I am using terminal with zsh with full disk access and when I enter --install-rosetta it states command not found. What am I doing wrong?

Sorry, not sure – I just pasted the line '/usr/sbin/softwareupdate --install-rosetta --agree-to-license/usr/sbin/softwareupdate --install-rosetta --agree-to-license" (without quotes) into terminal and it worked. You might try asking on the Reddit post linked there.

How long do you hold off?

Well I have not upgraded yet but its entirely up to you, my friend has said its ok to upgrade now so feel free. I will when I have time.

I would stress that you do a backup using carbon copy cloner or similar of your current drive and ensure your mac can boot from the backup before you upgrade. If you dont and the upgrade fails you could have a problem otherwise. Have fun.

Hoping for some help please. As there was a new version of Lightburn available today. I downloaded it and went on to install on Mac OS Monterey 12.0.1. (Just a note the previous Lightburn version I installed on the same MacBook Air in August was working perfectly) However I am getting this error message and when I check the instructions on the Lightburn site it does not describe getting around this new error notification. I would really appreciate any help as I have projects to finish for Christmas.

You said, “I am getting this error message” but didn’t include anything.

Are you seeing Apple’s nanny message about not being able to scan the app? If that’s it, just follow the installation directions here:
https://lightburnsoftware.github.io/NewDocs/Installation.html#macos-installation

Hi sorry I was trying to attach a screenshot but couldn’t find anywhere to do that. The message I get is copied below. It is a different message to the one mentioned in your link
“LightBurn” can’t be opened
because Apple cannot check it
for malicious software.
This software needs to be updated.
Contact the developer for more
information.
Safari downloaded this file today at
23:25 from
objects.githubusercontent.com.

It’s effectively the same message. Go ahead and try the steps listed in the link for launching for the first time. That should work. If it doesn’t come back with a screenshot of the error message.

You can attach a screenshot into the editing window by dragging and dropping an image from Finder or by pushing the up arrow icon.


Hi This is the message I get. As you’ll see there is nowhere to click open. I have followed the instructions which worked fine until this upgrade to Monterey

Can you show a screenshot of what happens when you right-click or control-click on the application? You should get an open option at that point. Are you saying it’s not appearing there?