Lightburn makes a lot of small cuts instead of a continuous line


Edit: it indeed was a user error. I went back to Inkscape and I noticed that the shape was over constrained if that is the right way to say it. I hit path->simplify and it was way better. It now cuts as expected. Thanks for looking. I am keeping this post in case someone has the same problem.

Today I thought about cutting an old design and I discovered something weird.

So… I have this design and when I try to cut it, the laser will actually keep cutting very small bits as if were to try and laser every few pixels. Back in the day this would just cut a line all the way, like you would cut for instance a square.

Full disclosure I believe it a user error (mine), but I cannot seem to find a solution to the problem. I hope someone can help. I still use the same Ruida controller I used before, but I guess some settings must have changed. No idea what I did wrong.

What I did discover was, when zooming in, is that there is not a straight line. I see a lot of curves. Is there any way to smooth this out? Maybe it has to do with that old SVG I use?

Thanks a lot !

Looking at this file I see that the shape is made up of several components and is not a closed path. Yes, I also see that the shape is made up of a bunch of nodes and small segments that change direction a lot. LightBurn does not currently provide a simple way to simplify shapes as you are thinking.

Select and Ungroup the entire file and you will find the shape is made up of 7 separate shapes, each with many hundreds and some thousands of nodes. Is this level of detail required?

This shape looks like it might have been traced from a map or some other shape with jagged edges and that has transferred over during the trace process. There are controls that will show the nodes being generated during trace where you have some control over the “smoothness” of the trace created.

The way this file is designed, a significant amount of editing will be required to “smooth-out” the cutting of this file.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.