Lightburn - Msg Reset To Continue after Hitting Limit Switch

I have a Genmitsu Jinsoku LE-1620. It has limit switches and only moves in the x-y direction.

My question relates to the message: Reset to Continue. This occurs after I have made a manual jog and hit a limit switch. And I believe I have seen it when the head moves in a program and hits a limit switch. How do you manual reset to continue so you can use the machine again to either jog or run a job over.

I have found the only way to clear it so I can have the machine reset and go to home is to pull the USB connection on the computer from the controller and plug it back in. Then it resets, homes and is ready to go.

I have read 2 ways to manually reset: click the devices button and click ok or right click the devices button. In either case, the program says its working the connection and then a series of error messages comes up indicating it did not reset.

Surely, there must be a way to manually reset, but I have not found it. Is there a setting I need to have set in preferences or something that I am missing? Help is appreciated.

Try homing to reset either by pushing the Home button or by issuing $H in console. If that doesn’t work, try $X to unlock. I’d suggest following that up with a homing cycle.

Depends on what you call ‘manual’… and don’t call me Shirley… :crazy_face:

This laser is supposed to have a similar or same controller… are these buttons available?

@berainlb comments are good to follow.

When a grbl board detects the limit switch, it knows it’s ‘lost’. If everything is ok then it would not go out of the work area. Once this kind of error occurs the only recovery is a ‘reset’ which generally includes a homing operation to know where it is.

The $X unlocks grbl commands and you need to home it next…


I have tried all the commands that you have proposed including $H, $X and Home Button. After I do this, Lightburn states it is busy and nothing happens. It does not clear. In each case, I have to pull the USB from the computer and reengage it, then it clears and I can go on. My unit has the current GRBL code so I do not know what else to do to rectify this issue.

My unit does not have a “manual” button like controller shown for the LC-60A. I can only do the clearing via software.

I think the best thing is to avoid hitting the limit switches entirely when not homing. I’d expect your soft limits to prevent this from happening anyway although I haven’t tested it.

Are soft limits on? Should be $20=1 if on.

Soft limits are off and hard limits are on. Once I change $20=1, how do I set the soft limits? Are they automatically set to some limit?

The working area is determined by the values you have in $130-$132 (X,Y,Z). So once homed, the controller has a conceptual understanding of the size of the machine. The soft limits enforce those machine dimensions.

You should still get a warning/error when attempting to exceed the soft limits but hopefully it doesn’t lock you out in the same way.

Then how are hard limits set relative to soft limits? Don’t they also control to the size of the machine area or are they outside the soft limits? My work space for the machine is X=160 and y=200. $130-132 were not set that way by the information I found for the machine, but rather recommended to be 1000 for $130-132. Why, I do not know. I assume since Z is mechanical knob and not motor driven, it either does not matter or should be set to 0?

FYI with $20=1… if I set the the jog to move 1mm into the soft limit, I can re-home the machine without issue, if I use a move of 10mm, it goes into “reset to continue” and I have to pull the USB to reset. So setting soft limits helped, but only for a small intrusion on the limit switches.

The hard limits are not relying on understanding an awareness of position in space to determine that a limit has been reached. It’s a physical switch that when activated relays that the switch has been reached.

For the purpose of most laser setups limit switches are used as a necessary component of the homing cycle and as protection from crashes (hard limit) on the 2 sides where the switched are installed. Stepper motors have no inherent understanding of their position. So when first power cycled the homing cycle is necessary to establish a known good position which is typically established as machine zero. The limit switches are used to stop the laser head during the homing cycle. You could similarly add limit switches to the other 2 ends to be used to prevent crashes. This would be useful in situations where steps have been lost or if the controller for some reason has lost track of position.

Not sure why that would have been. But normally these match working area and should also match the dimensions configured in LightBurn for the device.

Does not matter as you say.

The limit switches may be intruding in on your defined working area. What is your Home Pull-off ($27) set to? I suspect this will be 0. Set this to a few mm out, enough to cover the switch throw distance.

$27=2.0. I assume this means about 2mm beyond the limit. This would be consist with if I jog 1mm into the limits, it ends program and allows me to set and if I move 2, it requires a reset to continue. What level should this be set at?

I may be wrong in how it functions as I haven’t had to tune this myself but try incrementing a mm at a time until either behavior changes or it’s clearly not working. Mine is set to 3mm.

If this doesn’t work then turning off hard limits might be an option.

Thanks for your help.

You’re welcome. Were you able to get working how you like?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.