Lightburn not connecting Marlin board via USB

Lightburn cannot connect to my RUMBA board running Marlin It gets stuck on Waiting for Connection. I made the Device profile manually and selected Marlin as the connection type. Right clicking on Devices does not connect (just prints a new “Waiting for Connection” prompt in the console). Lightburn seems to continually send G0 but doesn’t get a response (that prints in the LB console, at least). Resetting the board in this state doesn’t change anything. Neither does unplugging and replugging the board.

Turning on “Enable DTR” in the Device settings pane doesn’t do anything.

Yet the Arduino app happily refreshes the board, and when I use the Mac Serial (“Decisive Tactics” third party) app I can successfully connect and manually send/receive commands. G0 works, as does M115 (I don’t have the board connected to anything else yet so these seemed like the only useful commands to test).

If I refresh the board and leave it powered up, then quit Arduino and start Lightburn, sometimes it partially connects (but doesn’t seem to hold the connection).

check for the baud rate communication, LB is set for default at 115.200

I have the same issues. Also have a board with Marlin 2.x firmware and it stucks a waiting for connection.

My workaround until now was only to

  1. Start the free Program called Pronterface (just Google it)
  2. Connect to the Marlin board - works always
  3. Disconnect and close Pronterface
  4. Open LightBurn
  5. Then it should immediately be connected

Would be great if you could find a direct solution to this problem without this annoying workaround😉


1 Like

Thanks, Pronterface/PrintRun connects reliably 100% of the time, but LB still never connects for me no matter the sequence :frowning:

1 Like

Thanks for the hint. LB (1.0.6 on Mac) defaulted to 250000 baud (no idea why). I had to make sure that “Enable DTR Signal” under tools->Device Settings is off, and the baud rate changed in that dialog to 115.2K, then restart Lightburn. Now it works reliably. :smiley:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.