Lightburn not connecting to Jtech laser

Need assistance. I just purchased a JTech 4W laser for my XCarve machine. I followed all the instructions and set it up as so. I am using the Lightburn software to run the laser as that is what JTech recommends but after I follow the set up instructions, Lightburn does not find my laser. All the instructional videos and blogs automatically assume Lightburn will find your laser. When I manually add my laser, I receive an Error Code 5. I’ve read postings that I need to install GRBL but the laser supposedly came with it installed. I’m running all of this on my Dell Laptop with windows 10. I am at a complete loss here and would appreciate anyone’s help. Thank you

Sorry you are running into issues with the ‘Find my Laser’ feature. You do have the option to set up manually. Are these the instructions you followed?

https://jtechphotonics.com/?p=10204

If you look about halfway down that page, you will see a sub-heading titled " Set Up Your Machine – X Carve".

We have seen this machine ships with an older version of grbl so go with the GRBL-M3 device in LightBurn. Ideally, you would upgrade to GRBL 1.1f and then use just the GRBL device. And, Try setting $10=0 - I think the JTech article is still missing this.

Yes, this is the site and instructions I was referencing. I guess I’m new to this but how do I actually install GRBL? Do that have to be installed on my computer? Another blog I was reading up on said to download the GRBL application from this site https://github.com/gnea/grbl and then import it into the Arduino library. Tried that and get an error. What am I missing???

No, grbl is known as “firmware” and is to be loaded on the control board that drives your XCarve system. On the page posted above, you should find instructions for how to go about updating your firmware (grbl) with links to the required files and tools to do so. Look for this section in the document.

Your controller should have come with some firmware installed and as I said, “We have seen this machine ship with an older version of grbl so go with the GRBL-M3 device in LightBurn. Ideally, you would upgrade to GRBL 1.1f and then use just the GRBL device.”.

Have you tried to set up a device in LightBurn? If so, what did you choose? If you type $$ into the console (just above the macro buttons) and hitting enter, what is displayed? Please copy and paste here. We can go from there.

I followed the instructions and I think it worked. I entered $$ on the line above the Macro and below is what showed up.

Thanks but to clarify, I need the entire contents of this console output window. There is more information that has scrolled up and off-screen in that window, as indicated by the scroll bar on the right side of that window. :slight_smile:

You can place your cursor inside that window and select all the text, then copy it (ctrl-c) then paste here (ctrl-v) so we can review the entire contents of that window.

And please, it is much easier for us if you answer all of the questions we asked. This is important information in providing appropriate help and solutions. So which device profile did you set?

This is all the information. I just turned on my system and I get the error 5 and then when I type $$ in the Macro0 field, all the numbers below show.

Waiting for connection…

Waiting for connection…

Grbl 1.1g [’$’ for help]

Homing

ok

error:5

$$

$0=10

$1=255

$2=0

$3=3

$4=0

$5=0

$6=0

$10=115

$11=0.020

$12=0.002

$13=0

$20=0

$21=0

$22=0

$23=3

$24=25.000

$25=750.000

$26=250

$27=1.000

$30=255

$31=0

$32=1

$100=40.000

$101=40.000

$102=188.976

$110=8000.000

$111=8000.000

$112=500.000

$120=500.000

$121=500.000

$122=50.000

$130=790.000

$131=790.000

$132=100.000

ok

When I went to set up the laser, I selected find my laser, but nothing was appearing. I then chose Create Manually and selected the GRBL-M3 (1.1e or earlier)

Error 5 is “homing cycle not enabled”, from GRBL. You likely have “auto home on startup” set in LightBurn in the device setup, but don’t have limit switches or homing enabled on your machine. Turn off the Auto-Home switch in the device setup screen and that error will go away.

First, you have grbl 1.1g firmware installed on you controller as reported from your $$ command. You will need to use the “GRBL” device and not the “GRBL-M3” device as that is for supporting earlier versions than you have. Make this change first.

As for the “error:5”, in looking up this error message I find the following from the document linked below:

error:5 Setting disabled Homing cycle failure. Homing is not enabled via settings.

This can happen if you set Auto-home in LightBurn and don’t have homing limit switches. Turn that off in LightBurn if you don’t have limit switches.

Here is what I get now after your instructions

Waiting for connection…

Waiting for connection…

Port opened, waiting for response.

Grbl 1.1g [’$’ for help]

$$

$0=10

$1=255

$2=0

$3=3

$4=0

$5=0

$6=0

$10=115

$11=0.020

$12=0.002

$13=0

$20=0

$21=0

$22=0

$23=3

$24=25.000

$25=750.000

$26=250

$27=1.000

$30=255

$31=0

$32=1

$100=40.000

$101=40.000

$102=188.976

$110=8000.000

$111=8000.000

$112=500.000

$120=500.000

$121=500.000

$122=50.000

$130=790.000

$131=790.000

$132=100.000

ok

There’s no error 5. That seems like you’re ready to go.

Thanks. I’m watching the tutorial now to get started. I appreciate all your guys help!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.