LightBurn not detecting Comgrow Z1 laser

Hello - I was successfully using LightBurn (LB) with my prior Lenovo laptop and, then, I replaced it with a Dell XPS 15 9530 laptop. I installed LB 1.6.01 but it’s not detecting the Comgrow Z1 laser cutter. The USB connection between the laser and the laptop seems okay as it does show up in the Ports list as “USB-SERIAL CH340(COM7)”. I tried the “Find My Laser” which filed and am attaching that log file. I also tried creating a GRBL device manually and attempted to connect, which it appeared to, at first, but just the terminal window just keeps stating “Waiting for connection…” - attaching that log file, too. I also tried reinstalling the latest CH341ser.exe driver from the manufacturer website.

LightBurnLog_06152024_FindMyLaser.txt (5.8 KB)
LightBurnLog_06152024_UsingManualGRBLDevice.txt (18.1 KB)

Did you try selecting COM7 in Lightburn Laser window dropdown box?

Yes, I did. I recorded the logs with the correct COM7 chosen (it’s in the logs). Thanks

Try changing the Baud Rate in Edit → Device Settings for newer boards is 230400 and for older boards is 921600.

You may need to do a power cycle for settings to became effective.

I had some success with power cycling the laser immediately after the change in baud rate. I had some errors and stops, but it mostly worked. Still testing. I’ll report back in a day or two.

1 Like

It won’t connect at all today, despite numerous attempts and restarts. I’m fairly certain that something is wrong with the laser cutter…LightBurn is a very good product.

Finally got it to connect consistently. It has to be at 921600 baud (my version of Comgrow Z1 firmware is 2.1), from the reboot of both LB and the laser, and it will work. This is resolved…thanks!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.