Lightburn not respecting $32=1; LaserGRBL does

I’ve read at least a half dozen articles/topics that all say clearly the problem is that my $32=0 not 1, but it is 1. And I still get those ‘tails’ on my simple circle and the laser just isn’t cutting off between lines/shapes in Lightburn. To make matters even more confusing, things print fine in LaserGRBL, so I don’t think it is my machine itself. I had hoped it was maybe a hiccup between the trial version and paid, so I bought the license, but still no dice.

Recommendations for what to try next? some of the internet seems to think I should consider trying to upgrade/update my GRBL on my machine but it seems like that’s a pretty drastic step.

; LightBurn 0.9.18
; GRBL device profile, current position
; Bounds: X0 Y0 to X50 Y50
G00 G17 G40 G21 G54
G91
M4
; Cut @ 6000 mm/min, 10% power
M8
G0X9.1Y5.71
; Layer C00
G1X-0.91Y0.78S100F6000
G1X-0.87Y0.83
G1X-0.83Y0.87
G1X-0.78Y0.91
G1X-0.74Y0.94
G1X-0.7Y0.98
G1X-0.65Y1.02
G1X-0.6Y1.04
G1X-0.55Y1.08
G1X-0.51Y1.11
G1X-0.44Y1.13
G1X-0.4Y1.17
G1X-0.33Y1.18
G1X-0.28Y1.21
G1X-0.22Y1.23
G1X-0.16Y1.25
G1X-0.1Y1.27
G1X-0.03Y1.19
G0Y0.2
G1X0.03Y1.19
G1X0.1Y1.27
G1X0.16Y1.25
G1X0.22Y1.23
G1X0.28Y1.21
G1X0.33Y1.18
G1X0.4Y1.17
G1X0.44Y1.13
G1X0.51Y1.11
G1X0.55Y1.08
G1X0.6Y1.04
G1X0.65Y1.02
G1X0.7Y0.98
G1X0.74Y0.94
G1X0.78Y0.91
G1X0.83Y0.87
G1X0.87Y0.83
G1X0.91Y0.78
G1X0.94Y0.74
G1X0.98Y0.7
G1X1.02Y0.65
G1X1.04Y0.6
G1X1.08Y0.55
G1X1.11Y0.51
G1X1.13Y0.44
G1X1.17Y0.4
G1X1.18Y0.33
G1X1.21Y0.28
G1X1.23Y0.22
G1X1.25Y0.16
G1X1.27Y0.1
G1X1.29Y0.03
G1X1.29Y-0.03
G1X1.27Y-0.1
G1X1.25Y-0.16
G1X1.23Y-0.22
G1X1.21Y-0.28
G1X1.18Y-0.33
G1X1.17Y-0.4
G1X1.13Y-0.44
G1X1.11Y-0.51
G1X1.08Y-0.55
G1X1.04Y-0.6
G1X1.02Y-0.65
G1X0.98Y-0.7
G1X0.94Y-0.74
G1X0.91Y-0.78
G1X0.87Y-0.83
G1X0.83Y-0.87
G1X0.78Y-0.91
G1X0.74Y-0.94
G1X0.7Y-0.98
G1X0.65Y-1.02
G1X0.6Y-1.04
G1X0.55Y-1.08
G1X0.51Y-1.11
G1X0.44Y-1.13
G1X0.4Y-1.17
G1X0.33Y-1.18
G1X0.28Y-1.21
G1X0.22Y-1.23
G1X0.16Y-1.25
G1X0.1Y-1.27
G1X0.03Y-1.29
G1X-0.03Y-1.29
G1X-0.1Y-1.27
G1X-0.16Y-1.25
G1X-0.22Y-1.23
G1X-0.28Y-1.21
G1X-0.33Y-1.18
G1X-0.4Y-1.17
G1X-0.44Y-1.13
G1X-0.51Y-1.11
G1X-0.55Y-1.08
G1X-0.6Y-1.04
G1X-0.65Y-1.02
G1X-0.7Y-0.98
G1X-0.74Y-0.94
G1X-0.78Y-0.91
G1X-0.83Y-0.87
G1X-0.87Y-0.83
G1X-0.91Y-0.78
G1X-0.94Y-0.74
G1X-0.98Y-0.7
G1X-1.02Y-0.65
G1X-1.04Y-0.6
G1X-1.08Y-0.55
G1X-1.11Y-0.51
G1X-1.13Y-0.44
G1X-1.17Y-0.4
G1X-1.18Y-0.33
G1X-1.21Y-0.28
G1X-1.23Y-0.22
G1X-1.25Y-0.16
G1X-1.27Y-0.1
G1X-1.29Y-0.03
G1X-1.29Y0.03
G1X-1.27Y0.1
G1X-1.25Y0.16
G1X-1.23Y0.22
G1X-1.21Y0.28
G1X-1.18Y0.33
G1X-1.17Y0.4
G1X-1.13Y0.44
G1X-1.11Y0.51
G1X-1.08Y0.55
G1X-1.04Y0.6
G1X-1.02Y0.65
G1X-0.98Y0.7
G1X-0.94Y0.74
M9
G1S0
M5
; return to starting pos
G0 X-9.1Y-5.71
M2

Waiting for connection…
Waiting for connection…
Grbl 1.1f [’$’ for help]
ok
[VER:1.1f.20170801:]
[OPT:V,15,128]
Target buffer size found
ok

$0=5 $1=25 $2=0 $3=3 $4=0 $5=0 $6=0 $10=0 $11=0.000 $12=0.000 $13=0 $20=0 $21=0 $22=0 $23=64 $24=0.000 $25=0.000 $26=8 $27=0.000 $30=0 $31=0 $32=1 $100=82.051 $101=80.004 $102=3.015 $110=500.000 $111=500.000 $112=500.000 $120=100.000 $121=100.000 $122=0.000 $130=200.000 $131=200.000 $132=-0.000 ok

This means that your lasers minimum power output value is zero, as is the max, meaning that the moment we turn on the laser, it’ll go to full power. Change that to 1000, and also verify that ‘S-value max’ in Edit > Device Settings is 1000 as well.

image

The reason it “works” in LaserGRBL is because that software works like GRBL-M3 mode in LightBurn, and sends explicit commands to disable / enable the laser output, whereas LightBurn uses G0 / G1 moves because they automatically turn the laser on/off, and it makes the communication more efficient to omit the other commands.