Lightburn not working after extending trial

Hi!

A few weird things happened at once today and need to get a fix!

I used the same project ive used plenty of times, changed no settings… when I hit ‘home’ it went to the back left and kept going, making that horrible clicking noise and triggering the ‘Left Limit’. It isnt catching any cables.

When I opened the ‘manual move’ screen and pressed the arrows it would do one of three things, either move properly, just judder or move diagonally… it wasnt moving up down left or right as normal.

Then when I went to burn the project, it came up with ‘project out of bounds’ even though it was all in the gridded program area, when i told it to continue anyway, it tried moving further back as if it wasnt at the top left corner. It’s almost as if it thinks its at the middle of the gridded area rather than the top left.

It worked perfectly fine on Friday in the exact same project, hadnt updated, has the latest firmware… it just seemed to change without changing.

To note, XCS works perfectly fine, i just much prefer the LB interface. This only happened once the free trial expired and they extended for another 15 days.

thanks

Dan

This is not likely to be related to the trial extension in any way.

Note that LightBurn is not involved in the homing process at all other than in being able to request a homing cycle.

If the machine is not homing correctly it will have something to do with the hardware.

Carefully examine the back left side of the machine. When homing is it failing to home on one or both axes? The homing relies on a metal tab coming into proximity to a sensor for each axis. Make sure nothing is getting obstructed, there is no damage to the sensors, and that everything is properly connected.

To confirm, you can home in XCS consistently and in Lightburn it consistently does not home correctly?

If so, please take a video of homing in XCS and in LightBurn.

1 Like

Thanks for the quick reply, I’ll aim to get videos tomorrow. It’s just the front-back axes (Y?) that it has an issue with. I’d already checked the hardware after reading other threads. Nothing seems damaged or obstructed.

If it was the sensor, why would lightburn be telling me my project was out of bounds when the image is within the grid?

It’s only in lightburn that I have a problem. It won’t even turn on the laser in LB (fan goes on, laser doesn’t move) but in XCS I just ran the same image perfectly fine without touching any of the hardware.

Homing is required to set origin correctly. If the machine is not homing properly the controller will report the incorrect position to LightBurn. LightBurn relies on that information to understand the relative position of the design to the laser.

I want to be very clear on this point. It’s not about whether or not an image can be burned. Does the machine itself home correctly when using XCS? As in the hardware functions differently when in XCS vs LightBurn?

Also, can you confirm which Start From mode you are using in LightBurn? Does XCS have a similar concept?

I’ll double check homing in XCS tomorrow but in LB the laser doesn’t work, in XCS it does.

I can finish a project in XCS, I can’t even start one in LB. In XCS it works without an issue, in LB the laser fan goes on but it doesn’t move and the actual laser doesn’t come one. Then the project says it’s finished.

I’ve only just started my engraving journey but with my graphic design background LB is so much better to use. I just don’t understand what changed over night.

In LightBurn, with your project set up similarly, and generating the same behavior, take a screenshot of the whole LightBurn screen and post it here.

Do you have a rotary tool for your xTool D1? Have you used it recently?

I have no idea about start mode, really new to this!

Today’s it’s homing without juddering but I’m still having the issue of it doing nothing when running a file that worked the day before.

A video is attached here; Dropbox - Video 13-02-2024, 12 57 04 pm.mov - Simplify your life

Thanks John,

Screenshots here, let me know if you need to see any other settings and where i’d find them.


A video of what’s happening is here: Dropbox - Video 13-02-2024, 12 57 04 pm.mov - Simplify your life

Surely if XCS is working and burning ok then it’s a sofrtware/settings issue in LB rather than a hardware issue?

In the Laser window, you have “User Origin” selected. Unless you’re very familiar with these concepts I’d suggest switching that to Absolute Coords. This is the most intuitive mode where the placement of a design in workspace will be replicated on the laser bed.

What changed? If nothing, then it’s very likely that the issue will return.

You don’t show the analog on XCS but this gives some clues.

A few considerations:

  1. Use absolute coords - this may actually be root cause for what you’re seeing but hard to tell from the limited information available
  2. Reduce the speed of your cut settings. This isn’t likely root cause in your case but it may be masking other issues
  3. In Move window, try the jogging controls. Does left move left, right move right, up move up, and down move down?

Retest and report back your findings.

Due to the way that xTool machines work this isn’t actually directly comparable. It can tell you if basic mechanics are working but anything above that is processed differently within the xTool controller.

Thanks!

Did as suggested and ran it again and the same issue occurs with homing. Except this time, if I start the project with the laser in the top left, hitting start it judders as if it’s trying to move further up. It’s as if the coordinates for ‘home’ is actually somewhere at the bottom of the workspace.

Interestingly, in a new file, I put just a rectangle on the grid. Hit ‘frame’ and it framed exactly where I expected it to… hit start and it did nothing but switch on the fan

Tried the move function and rather than straight, it’s moving diagonally once. If I press the same direction more than once, it doesn’t move, just judders with each click.

This is very odd.

Bottom line, if your machine doesn’t home properly you could get odd behavior but I wouldn’t have expected diagonal movement.

Question, does your machine home automatically when turned on or only upon connection with LightBurn? If the latter, I’d like to take homing out of the equation to see if that resolves the core issues.

Disable “Auto-home on startup” in Edit->Device Settings. Then turn off the laser, move the laser head to top left, then turn on the laser. Connect with LightBurn. Push “Get Position” in Move window and confirm that it shows 0,0.

Then test jog controls in Move window. If that works, test a job. Make sure you’re using Absolute Coords.

What are the results?

It only homes when I command it to.
Neither on start up or connecting with LB. Made sure homing on start up was off. Reopened LB and connected.

‘Get position’ top left is 0.0 - if I manually move it elsewhere and ‘get position’ it still says 0.0

Move command - the first command goes straight, any other command goes diagonal.

Can you take a screenshot of Edit->Device Settings?

This is odd.

Does it go in the direction requested?

Do jogging controls in XCS work correctly?

It goes in the direction requested, then diagonal in the rough direction requested.

Jogging in XCS works correctly, framing is only from where the laser is at that moment rather than grid coords. just tried ‘home’ and it did the same thing in the top left hand corner as in LB


Your device settings are a bit odd. I suspect this is using a new xTool device type which I’m not familiar with.

That’s somewhat comforting. You really need to narrow down why the machine is not homing properly. There’s likely an obstruction or the tabs are not quite reaching the sensors comfortably.

Try one thing. Try recreating your device using the .lbdev file provided for your machine by xTool.

Operate xTool D1 Pro with LightBurn - xTool Support Center

Check if this resolves the jogging behavior as that’s still a bit of an anomoly.

I’d also suggest connecting with xTool as they may have some suggestions for how to address the homing issue.