LightBurn not working with xTool D1

I have had the same problem for 20 days now. I only have 10 days left on the trial, I hope this will give me the answers im looking for. So if you get it to work please share how

You may want to try using one of the alternative firmware update methods instead of relying on Laserbox.

How to upgrade the xTool D1 firmware – xTool

Yes I found that link as well. I’m going to try it tonight.

I upgraded the firmware on the xTool D1 to “V40.30.002.01B1_20220110” and now it works with LightBurn.

Following the instructions here How to upgrade the xTool D1 firmware provided the neccessary application and files to perform the firmware update. Just remember to enable the Update Firmware Switch on the xTool D1 controller board before starting the upgrade and be sure to dissable the Update Firmware Switch when the upgrade procedure is complete. Then cycle power on the xTool D1 before starting LightBurn.

The “Check for Firmware” button within the Laserbox Basic software did not recognize the need for an update. After researching several websites and documents and suggestions from this post, it seemed logical that the firmware on the xTool D1 was not up-to-date. Using the Firmware Upgrade Tool from xTool worked.

Below is the first project I ran from LightBurn and it turned out perfect.

That is a 4" round coaster that is 5mm thick. The settings I used in LightBurn were 112 mm/s at 25% power with no air assist.

Now I feel confident in purchasing the LightBurn software. I just need to learn it inside and out now. Wish me luck. I’m certain I’ll be visiting this forum frequently for guidance.

Huge thanks to all of you that participated in this post. Hopefully this info will help someone in the future.


Hi David, I am glad you were able to work it through to success.

Can you please show the switch you are referring to for the update before and after?

Below is a picutre showing the switch for enabling firmware updates.

Looking at the picture, the button left of the “Upload” switch is a reset button. If the Upload switch is pushed away from the reset button, firmware updates are enabled (Upload Mode). If the switch is pushed toward the reset button, firmware updates are disabled (Operation Mode).

once I figured out that LightBurn was not working properly with Xtool D1, I returned it and bought a real laser (OmTech).

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.