LightBurn not working with xTool D1

I just setup a new xTool D1. I downloaded and installed Laserbox Basic from xTool’s website. Performed update check on Software and Firmware and was notified I have the latest version of both. I’ve ran a few projects using Laserbox Basic and everything works great but their program is just too limiting.

Yesterday I downloaded and installed the 30 day trial of LightBurn (Version 1.1.04). Set the program up following xTool’s instructions. Installed xTool’s device driver “xTool-D1-V2.lbdev”. When I start LightBurn my xTool D1 indicates that it is connected and ready but the xTool D1 doesn’t respond at all. When I click the Frame button it doesn’t move at all. When I click the Start button it doesn’t do any thing except give me an error message “There was a problem sending data to the laser. The machine may be busy or paused”.

The xTool D1 still works fine with the Laserbox Basic software.

I really like the features of LightBurn and want to purchase it but unless I can get it to work with my xTool D1 I’ll be unable to do so.

I’ve emailed Makebox but no response yet.

Any ideas what I’m doing wrong or what I need to do for it to work?
If I need to provide any additional info I’ll be happy to do so, just let me know what.



Are you connected via USB? Do you see the connection in the “Laser” tab? Do you see a comm port in the in the Devices section?
Lightburn Connection to D1

I am also having this exact same problem. Here’s a screengrab of what I see.
Screen Shot 2022-06-27 at 10.44.49 AM

Yes I’m connected via USB on Com3. I’ve tried another USB port and it connects on Com4. Neither seem to work although LightBurn is indicating a status of “Ready”. I’m using a USB cable connected from a laptop directly to the xTool D1.

Do you have one of those silly Big Red E-Stops on your laser? Is it pressed in? I fell for that one once.

No the xTool D1 doesn’t have one of those.

Just so I am clear, you do have a file loaded and selected for the burn? Does your laser head move if you give it move commands? Will it frame? Do you intend to use “Current Position” as your Start From?

For me, I do have a file loaded. The head does not move if I give it a fram command of any kind. I’ve tried starting from all three positions.

David, if you click on the xTool D1 in the Devices setting, is there only one xTool D1? What does it say in your console window? Also, I assume you have tried rebooting?

I am digging around for info. You might have seen this: Light burn Xtool D1 waiting for connection.

David, you mentioned that you installed the driver. Did you import it into Lightburn?

Jeff, yes I do have a file (a square cut line with a circle to engrave in the middle of the square) loaded and selected to burn. The laser head won’t move at all even while trying to Frame. The instructions from Makebox says that the Move Buttons won’t work. Yes I intend to use “Current Position”, and is suggested from the Makebox instructions.

Yes there is only one xTool D1 showing in the Devices List. I have tried rebooting several times for the laptop and the xTool D1. I did read through the link you provided but that didn’t resolve anything. I even tried to use a previous revision of the xTool driver but still no luck. Then I re-installed the most recent driver from xTool. The installation proccess of the driver is per Makebox’s instructions by clicking on the “Import” button and selecting the file (xTool-D1-V2.lbdev).

In the Console pane it displays “wainting for connection” , then it just repeats “OK:512 and OK:IDLE”.

I’ve captured several screen shots I’ll post ASAP.

Here are some screen captures that I aquired. Hopefully they will help.

More screen captures:

I connected to my xTool D1 and compared my settings to what you have shared and they are the same. Hopefully someone is familiar with this issue and can help you resolve it.

Console with move commands performed
Captures of my console when I connect the D1, and when I issue a few move commands.

I’m not sure LightBurn is talking to my laser at all. Reading through the forum I noticed several people typing $$ and $I in the command line within the console. When I type these in the command line I get nothing. What are these commands suppose to do? My console just keeps displaying OK:512 and OK:IDLE after typing them, what do these mean?

I’ve tried clicking on the “Get Position” button but nothing happens, no activity shows up in the console except OK:512 and OK:IDLE.

Am I running the latest version of firmware for the xTool D1?

Seems to me that it’s talking to your laser. However, it doesn’t seem like your laser is running in GRBL mode.

I’m going to guess this is the problem.

What version of Laserbox are you running? Is it possible that the version of Laserbox determines the firmware that’s presented to you?

xTool D1 Laserbox Basic Software-For Laser Newcomer – xTool

I’m running Laserbox Basic version 1.2.0

Ther firmware version is V1.0.0.B41. Laserbox says this is the latest version when I run the Update Firmware check.

Well I finally got an email response from Makeblock (xTool). Their suggest was to exit out of Laserbox before starting up LightBurn. I’ve done this and rebooted the laser before starting up LightBurn but it just doesn’t work.

The link PY provided in the previous post suggest the Firmware V40.30.002.01B1 should be used for Laserbox Version 1.2.0. This is not the firmware version indicated for me when I perform the Firmware Update check in Laserbox Basic. So I replied back to xTool to see if this could be the problem. I’l wait and see what they say.