Lightburn now asking for a license key all of a sudden

My software has all of a sudden started asking for my key. Even when i enter it it says its active but Lightburn just closes itself after a few seconds.

I am having exact same issue. hopefully someone has a fix for this soon

Same it’s showing that I don’t have light burn at all.

Same Problem. When I launch LB, it asks for the key. I enter Key and it says it is expired but that I can continue using older versions. When I say “OK,” it shuts the program down.

same here worked last night

My license was expired, so i renewed it and that fixed my issue, even though you are supposed to be able to use the software without renewing. I know this is not the way its supposed to work, but that’s what worked for me.

yep. got me too

I just entered my key in again and it worked. So keep trying and hopefully it will work for the others who are having the issue

i have the latest build not going to renew to fix it they need to fix this on their end

Beth, did you have to have dashes in certain places? When I tried to paste mine in from the activation email I got when i originally purchased, it was rejected due to dashes/spaces missing. Ideas?

Support let me know they are having a server issue. They hope to have it fixed soon.


Thanks for letting us know! :slight_smile:

tengo el mismo problema, entro al programa y me dice que mi licencia caduco, re ingreso mi clave y no me deja trabajar

@heritagefarmhouse Yes, I put in all dashes…exactly as it was sent to me originally. I tried 5 or 6 times, then came here to the forum to see if others were having issues. I unplugged my USB cord and restarted my computer and tried again and that’s when it worked and I’ve been fine since. But a comment above says someone talked to support and they said they are having server issues. So I think it’s LB’s problem and hopefully things will get resolved for everyone.

1 Like

I cant believe it would take this long to migrate everything over to a new server they must know which one is bad.

Yea, mine started doing that this evening, and projects I had getting ready to do, won’t work. Had layout on honeycomb, and did a check by framing, then told it to “start” and wouldn’t do anything, and I could use the frame button, but start button did nothing, even thought software said “ready”. I need my machine working.!!!

Same here. Tried opening the app to work on a project and it won’t stay open. Would reinstalling help? I just upgraded my license recently for my Fiber laser, I’d hate to lose all my settings.

Same Problem here, Lightburn is not longer activated. Both 2 Licenses :frowning:

Hi, I am a possible new customer for Lightburn. But now reading this I am concerned…
I do not see a official response from Lightburn on this issue here or am I missing it?
How long did it took to get this resolved? Is it resolved?

Our license system provider changed something that caused an issue for a relatively small number of users. We gave them the info they needed to track it down and correct it, and it was resolved that day.