Lightburn on Fiber laser with Rotary Chuck doesn't return to start, stuck in framing

Current version of LB on a Mac Running Ventura with a ComMarker B4/30watt Fiber laser and a XTOOL RA2 Chuck Rotary. I have the settings to return to center after the burn, but it never does. It’s stuck on Framing in the “READY etc” spot and I have to either quit LB or turn off the Fiber laser to get it to reset so it shows ready.

Your time and assistance are greatly appreciated,
Matt Caswell

Do you have the proper steps/rotation for the rotary you are using? This is based on the steps/rotation of the motor driver…

Do you have the right axes selected?


My rotary has been configured based on the stepper motor, all switches set correctly. It tests 360° perfectly around and back. It burns perfectly, it just won’t return to center and is stuck on Framing.

Thanks for taking the time to respond with your questions.

There is an option in the rotary gui return to origin. Do you have this enabled?


Yes I have it set, on the fiber laser Galvo there is no option for user origin etc. But there is a setting to return to start which would be the center of the design.

Thanks for your time,

It returns the rotary to the original position… when you started the job. There is no user origin on a fiber that I know of.


But it doesn’t return to the original position. It just stops at the end of the burn and says “Framing”. Here you can see the position it stopped at and in the control panel you can see it’s done but says “FRAMING”

Screenshot 2023-12-31 at 11.06.33 AM


If you click go to zero?


Hello, Matt
More questions I’m afraid, at what point in the burn did you take this screen shot?


I’ll try that and see.

thanks for the suggestion

at the end of the burn, you can see that it sliced all 3445 and just quit burning and never returned to the starting point. Perhaps this feature Doesn’t work on Fiber lasers?
Maybe since the center is 64mm, when it finishes on the left edge, the position is “0”. I’m smart on Diode and LB, but I’m LB stupid on Fiber lasers I guess.

Thanks for the questions,

Your answer is what I thought. I have rotary/ fiber so that is not the problem, it behaves exactly like you wuld expect, finishes the burn and returns to zero. In your case it is clearly stopping prior to returning to zero. Have you tried something with less slices and / or a larger split size? 3445 is not that much, but curious if it is a memory issue. I have maxed memory out with LB, it usually resolves after a bit and continues on, doesn’t freeze up forever. Is there any other software open?

You can dial your power down to 0 or 1 and experiment a little bit.

I have 128GB of Ram in my 2020 iMac 27" and have plenty of memory left.
I’ll do some research on the split size parameter.

Thank you for all you’ve done to try and assist me!

Tried clicking on go to Zero and it doesn’t do anything.

Thanks for trying.

1 Like

I agree with you something is freezing it up. I only have 8 gb ram and ive had up to 10,000 slices.

I’m wondering if it’s the fact that I’m using the XTOOL RA2 rotary which is made for their Diode lasers. It works great except for the fact that it won’t return to start. I never have that issue when using the RA2 on my XTOOL D1 20w Diode.

One other thing to mention. I used one of my RA2 rotaries in a vertical mode to do 8 biz cards on a horizontal jig and it does all 8, then returns to start, but using REPEAT Marking doesn’t have me enable rotary even though it uses it.

Thanks again for all the assistance,

1 Like

I doubt it is a problem with the rotary, especially if it returns correctly during test. They are such a simple device. Here is something to try if you haven’t, turn off “Return to Start” Run a small test vector, and then see if the “go to zero” button works or if it is still locked up. I think it is likely a software conflict or something like that.

Maybe @Rick can give you some tips… or send a note to support…

As @Albroswift advised, a rotary is a rotary and shouldn’t make a difference…

Hang in there as it’s new years eve and some of the Lightburn are enjoying the holidays…


Thanks Al, I’ll try that.