Lightburn on Mac Air, unable to connect to Creality Falcon 10w

Have a MacBook AIr M2 operating on Sonoma 14.2. Am trying to connect Lightburn with my Creality Falcon 10w. I tried to make the LIghtburn Material test, but kept getting a message saying laser may be busy or off. It is on, an not busy. Tried connecting via internet and thunderbolt c connection. The laser does not have a USB port, just C port and SD drives. My Mac only has thunderbolt c ports. Any suggestions?

You said that the laser does not have USB port, just C. This is a USB-C port and you should be able to connect the port to your thunderport (USB-4) on your computer. You also said the you tried connecting via internet and thunderbolt c connection. Maybe the cable is bad? Does it work with other connections?

When I connect to mine, I need to choose the connection port. (see documentation here: Connecting to a Laser - LightBurn Software Documentation - I’m not sure if you have done this or tried it. It should give you at least one option to select.

Hope this helps.

Thanks for the helping hand! I have tried the USB C to USB C, and that is when I’m getting the laser may be busy or off message. I’m going to re-read the software documentation and see if it makes more sense to me today - thanks again!

Macs with USB-C only tend to be quite picky about how it negotiates host mode with another USB-C device.

Try putting a high quality powered USB-C hub in between the Mac and the laser.

I did purchase a top rated hub, and I’m waiting for a new USB C cable to come in. While my current one was well rated, it was rated high for speedy charging, no data transfer, which my new one is rated well for. Maybe this will be the magic combo!