Lightburn regular or beta not working with GRBL Controller

Not sure if this is an issue but it is for me. I have a setup running the GRBL controller and in windows 10 everything works just fine on the Public released LB but when i try to use it on a windows 11 PC in Beta it will not recognize the GRBL controller.
Update. Also on the Windows 11 PC i installed the same version as my windows 10 pc and still does not recognize the GRBL controller.


Windows pickup and installs the controller and it shows up in LB as a port but it will not connect. i have tried updating the drivers etc. and still will not work on a the Windows 11 PC for some reason. if i take it back to my windows 10 PC it works just fine.

On the windows 11 machine, Is there another COM port available for selection in the LightBurn Laser window?

COM22 seems somewhat unique.
Do you have a USB hub with several devices plugged in?

i can adjust the com port for the controller but that does not help because no matter what com port i give it, it always says it is already in use. I have use it on both external ports of the laptop, with and without a hub and also unplugged everything else but the controller and still no joy. but i can hook it up to any Win 10 PC and it works just fine…

When you moved to Windows 11 did you install the CH340 driver?

If not, Step 5. on this instructables link may help.

1 Like

Dude!!! You are the MAN!!! Fixed… Thanks!!!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.