LightBurn runs on $2.10 Linux tablet

I have LightBurn running on some cheap tablets I got from a Hack-a-Day post a few weeks ago. Mike got thousands of these surplus units and is charging just shipping and packaging expenses. I got 10 for $21.

They come with Linux Mint v20.04.2 installed and everything but the cameras work on the few I’ve tested. I just got LightBurn to run on these tablets with little effort. It installed using the installation app and all I had to do was copy from another machine into the .local/share/LightBurn/lib directory so that the Update Manager can phone home to check for updates. Otherwise it worked out of the gate.

Any permissions on the USB side are non-issues since this is standard hardware and any of those issues, if they show up, are easily fixed with group settings and possible udev device rules configuration.

I used a script from a Dell machine to get auto-rotate to work and all I had to do was pull the Laser and Library tabs into the upper “Move/Layers/…” section so it fit in the 800 vertical pixels since it’s 1280x800.

Given these have wifi built-in, I can see SAMBA, NFS or just scp copying my design file to this and loading it up at the machine so I don’t have to move my laptop around. More stable than the rPi remote USBIP option I’ve been using.

PopOS seems to be a very smooth tablet OS so I might give that a try. If only because it does auto-rotate already and any time a text screen pops up it will pop open a virtual keyboard. Quite handy for tablet-only operation.


I booted PopOS 21.10 v3 off of a USB thumbdrive and got LightBurn running with that too.
PopOS has automatic screen rotation and virtual keyboard pop-up built in so way easier to use without adding an external USB keyboard and mouse.

Here’s a screenshot I grabbed from the PopOS testing:


By going into the LightBurn Settings and increasing the Toolbar Icon Size and the Font Size it really become much more ‘touch’ capable. Touch capable problems I’ve run into:

  1. I see is that on the left vertical tool icons the “expansion” button does not resize and is still a tiny double down arrow button.

  2. the Settings dialog there’s a bunch of unused space below the last setting which at more than 15pt font it puts the Cancel / OK buttons at the screen bottom edge and it’s hard/impossible to click them. On this screen, 800 pixels high, a font of 15 points is usable and it helps to hide the bottom launch bar.

Hey Doug. Thanks for sharing this. Do you know what the original branding and model are for this? What kind of specs does this have?

I think if the camera could be made to work this would make a very compelling dedicated production station where the camera is used to monitor jobs.

from the kernel output obtained from the BIOS:
Vulcan Electronics VT1018XC32/VT1018XC32

cpuinfo shows:
Intel Atom x5-z8350 CPU @1.44GHz

meminfo shows:

Flash disk is 32GB

why not just use a USB webcam so you can point the camera while still having the display visible? Besides, the cameras are going to be a PIA since they are tied to the onboard Intel x5-e8000 media chip and support for this has been problematic. Google the chipset and all the different tablets people have been put Linux on and can’t get the cameras working.

Thanks. So essentially modest but workable specs.

As for the camera my interest in using the builtin is more about a “one less thing” to worry about approach. Not having to sort out another mounting solution, routing, USB, strain relief, etc. and frankly wasting available hardware. I saw a similar approach with using OctoPrint on older Android phones for 3d printing.

I wasn’t aware of issues with the Intel x5-e8000 media chip but that’s unfortunate.

Have you sorted out a solution for the open back?

OctoPrint works because it is not really a display but instead a web server so pointing a phone which is a webserver and the primary UI is a remote browser seems quite different from pointing a 10" at something and still using the display. I see your point about dealing with all the lines, possible USB hub etc.

Supposedly there is a Media_tree kernel where this chipset works but the MMAP interface does not so only one special camera app currently works. So the builtin cameras will likely stay idle for a while.

As for the open back, there’s an STL file one can print and there are also cases for that Vulcan tablet model which would effectively give you a back. Refurbed cases go for $20ea from

Ah. I see where you’re coming from on this. I wouldn’t intend to “use” the display other than as a way of initiating and monitoring the burn. There’d be little in the realm of actual interaction other than loading a file, framing, and starting a burn.

But you’re right, having the orientation of the whole tablet being dictated by the camera angle wouldn’t be ideal.

I could see one of these mounted to the front a laser with the USB cable going back into the equipment bay to a hub where the power supply resides and possibly a memory card and/or camera and then be used for the setup work you mentioned then hitting the run button. I don’t know if LightBurn gives up camera access once it’s running or not but if it did, then an fffmepg stream could be used to send the video.

This is really a pretty standard x86 machine in that I can boot from Live USB’s through the BIOS boot selection and install any variation of Linux OS on these. It came with Linux Mint 20.02 and LightBurn runs find on that but outside of LightBurn the system buttons and icons are too small so I’m looking at PopOS and will give that a try. It boots off of a live USB and another person has already installed it. With PopOS I think there’d be no need for any external keyboard or mouse.

There are 3D model files for back covers too and I think soon there will be a USB-C connector holder for easy powering of the device.

I’m running my Ortu diode laser with LightBurn on this little tablet via Touch only! After installing LightBurn, I just needed to run the group setup commands as listed in the Linux Installation instructions:

sudo adduser $USER dialout && sudo adduser $USER tty

Now, does anyone know if there is a way to trigger the fire button during Frame operations(visual outline) without a keyboard or with only the keyboard(virtual keyboard)?

1 Like

I’ve been curious about this myself, specifically the keyboard shortcut. Have you tried combining the virtual keyboard with touch for the frame button?

A possible workaround that’s a little cumbersome is that you could create a shape in LightBurn that mimics the frame, then assign that to its own layer with a very low setting that matches the frame power and speed. Then literally run a job with just that layer selected.

You could do this with even the rubber band frame by using Arrange->Create rubber-band outline from selection.

It clutters the design a bit and slightly cumbersome but works well.

I’ve had to do this when I’ve had some particular framing requirements/shapes that didn’t match the square and rubber-band shapes. This is very useful for when trying to burn on used material that’s not a regular shape.

1 Like

On this screen and in the landscape format(better for LightBurn layout) the keyboard covers the Frame buttons.

While a solution it’s not something I want to add to the workflow if I can help it. Heck, I would code up a uCPU to fake the keyboard shortcut if I had to. There are tiny Arduino Leonardo compatible boards called Beetle which support USB HiD emulation so emulating a keyboard button press is doable. Need a shortcut directly to the feature though.

Well, you could send a shift press and touch the fire button on screen.

Instead of a HW solution, though, perhaps you can do a custom virtual keyboard layout that only takes a portion of the screen.

1 Like

what does that do? Normally, with the Fire button active it will deactivate once I hit either Frame buttons.

good point

Sorry. I misstated. I meant to say send a shift and touch the frame button on screen, not fire button. But I might also be misunderstanding what you wanted from this. I thought you wanted the ability to frame with the laser on in order to see the boundary.

Do you know what virtual keyboard you’re using?

It dawned in me after I’d replied that you might have mistyped that. Currently the virtual keyboard pops up from the bottom and in that position, on an 800 pixel vertical resolution screen, I can’t get to the Frame buttons. I will have to see if I can code up a multi-touch feature since this OS, Pop OS, supports 4 finger swiping already. Maybe something like a 2 finger followed by a 3rd and do the Shift-Frame message event.

I think it is gsd-keyboard on PopOS 21.10 v3

Why not write a GRBL script to frame and turn on the laser?

How do you envision doing that? You’d need to get dimension information at the minimum for a rectangular frame.