Lightburn sculpfun moves left to right without lasering

Hi guys

I am completely new to this (3
Days since I got it) and after a few test prints which worked out great I have this problem.

I am using sculpfun s10 without endstops. Lightburn software.

The machine has been turned off and on at zero location front left. The auto home feature in lightburn is off as you can see.

I tried reconnecting the cables.

I tried reinstaling the software.

I tried instaling the software on another laptop, first prints went good, and then the third for no reason that I know did this again.

So, I add a letter, I frame the letter and it is on the correct position as you can see on the video. But when i clock start ot just goes left to right without doing anything. This was im absolute coordinates but it does exactly the samr thing if I set it to current position.

The garfield print was done with lasergbrl and it worked just fine but I think i would preffer using lightburn.

Any help and thoughts would be appreciated.

  1. What does Preview look like?
  2. Can you take a screenshot of cut settings?
  3. If you save the gcode and run in LaserGRBL what is the result? Does it match LightBurn or something else?


it seems you are on to something, the preview indeed looks strange, any idea why?

I tried exporting the letter a from lightburn to lasergbrl as a .svg and it worked just fine…

here are the settings

If you look at the calculated value of Overscanning in your cut settings it shows 125mm.

I suspect your work area dimensions are incorrect. Can you take a screenshot of Edit->Device Settings?

I didn’t mean for you to export as SVG. I was expecting you to save gcode and run it. But this test is no longer necessary since it’s already been proven that your laser is likely doing what it’s asked.

It did not find the sculpfun automaticly so I added it manualy, but the only dimension it asked were the size, and I entered it 410/400 and selected GBRL as device. Here is the requested image.

That looks fine. Can you save the .lbrn test file and upload here for review?

You are using the wrong units. You set the layer speed to 5000mm/sec which is 300.000mm/min. And the laser is only capable of 6000mm/min (100mm/s). That’s also why there is so much overscan.
Change the units to “better for diode” in main settings. Then try again. Additionally, 5000mm/min is still too fast for decent quality. Start with 2000-3000 mm/min and start experimenting.
For reference, see here how to configure LightBurn for use with an S10 laser: Setting up the software - Diode Laser Wiki
And here is an overview of the main topics you should care of: Quick Start & Overview - Diode Laser Wiki


thank you both, Misken, that was it, thank you, I will get to RTFM now thank you,

one more quick question, since I do not have end stops yet, is it the same thing if I click set origin when it is at the front left position as turning it off and on again?

More or less. In the end, this depends on which mode you use afterwards. For the beginning, until you are familiar with all features, the safest way is to move it to the front-left before powering on to have a consistent coordinate system feeling. More info is also here: Coordinate systems & workpiece alignment - Diode Laser Wiki
You can set an origin at any position, that’s why it is not completely the same.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.