Lightburn showing as disconnected

Using MacBook Pro with new Orion 50w says RDWorks so my understanding it would be under Ruida.

Set up manually. Automatic setup never saw device. When I plug the usb into my Mac from the Laser the laser acknowledges connection.

I’ve tried rebooting Mac, unplugging Laser as per what Ive read.

What else can I do. I want to buy the full version of Lightburn and use it but not if it won’t work between my Mac and my laser.

connect via ethernet cable no probs on the Mac

I have a new MacBook Pro. No ethernet connection on my Mac only two usbc ports

Mac, Ruida Controller, doesn’t recognize USB

This is a known problem do a search on the above

Ok so I found my ethernet connection and it’s till not working. I set up ip address as specified on help topics and Lightburn is still showing device as disconnected

Are you able to ping the laser from your computer in the terminal? How is the laser connected to the computer? (wired cord, though a router or switch, etc?)

Ping isn’t showing it on my MacBook. I have tried connecting with apple port that allows USB to USBC or a port that connects with USBC and has an ethernet port

Sorry to be pedantic, but you’re running a cable from the Mac to the laser, correct? If you can’t see it with a ping then LightBurn won’t connect either. Make sure that the laser is on the same subnet as the computer (first 3 numbers of the IP address is the same) and that nothing else is using the same IP address. You should also see “LAN: ON” in the lower right corner of the display on the controller.

It says LAN off. I am running cable yes. First 3 numbers are the same IP.

I did what was recommended in another thread. To take your network IP and subtract 100 and make that your device IP. I did that and configured that IP address in device then edited setup for lightburn for that device with matching ip.

Ok so now I decided to run Lightburn on my old Macbook I figure if all i’m doing is running the laser off it I’m good.

Now laser says lan on. I ping ip address and it keeps saying 64 bytes from…

But the device still shows as disconnected in lightburn

I am running a direct ethernet cable from device to MacBook

Right-click the ‘Devices’ button in LightBurn to have it re-attempt the connection. If it finds the laser, you’ll see 'Found RDC644xG" or similar at the bottom of the display.

Can you show me a picture of the IP settings on the controller, the ping result in the console, and the IP address you set in LightBurn?

Here are the screen shots and pics

![unnamed-4|375x500](upload://qv![Screen Shot 2020-05-30 at 10.40.19 AM|612x402]

(upload://yHfRa7Vl8UQ5yOQhg0nZHNwBsQI.png) ![Screen Shot 2020-05-30 at 10.39.28 AM|549x451]

(upload://gZPBjVVblN1L9SxyNBtBo9350he.png) P3vABquXk17NOez85PcTGpogh.jpeg)

Screen Shot 2020-05-30 at 10.40.19 AM Screen Shot 2020-05-30 at 10.39.28 AM

What’s the IP address of your computer?

From what you’ve shown here, I don’t see anything incorrect, but it does depend on your hardware and network configuration a bit. You also mentioned that it’s an old MacBook, so it’s feasible that it doesn’t have auto-detect of direct-to-device connection.

Ethernet cables are set up to be connected from a device to a switch or router. If you want to connect directly between devices, at least one device needs to be able to detect that it’s directly connected to another, or you use a crossover cable, meant for connecting directly between devices. It’s possible you need one of these (they’re pretty cheap), or you can use a crossover adapter with a normal cable:

ip address is

I’ll see if i can pick up adapter

Computer is a 15" MacBook Pro 2010

That could be the problem: different subnet. Set the laser to be The first 3 sets of digits should be the same between the laser and the computer.

Now its showing this when I ping and I changed Ip in lightburn and on laser to what you recommended
Screen Shot 2020-05-30 at 12.05.49 PM

You might need the crossover cable - I can’t think of why the other address would work and this one wouldn’t. That’s very odd. Do you have a network router or switch you can connect both devices to? That would skip the need for a crossover cable. This is usually a pretty trivial process, so I’m not sure what’s happening here.

The gateway IP on the Ruida controller is strange. I’m curious what the subnet mask is seeing as the MAC is on a network and the laser pinged with 192.167. Then seeing as that gateway IP.

The Ruida controllers are Auto MDI and just about any new Ethernet controller is as well, so a cross over cable prob won’t make any difference.

If your MacBook is on your home network via WiFi (for internet access), and you’re using the Wired Ethernet to connect to the laser, your computer has two ip addresses.

The IP address of the Ethernet adapter is what matters here. Moreover, the configuration of the Ethernet adapter on the Mac book is where you need to start.

Let me suggest you configure the Ethernet adapter on the Mac Book to use a static IP address On the same network as your WiFi.

And set the laser on a static up on the same network as your WiFi. Use the same gateways as your WiFi.

I think the ping worked because your MacBook was bridging the connection.