Mac, Ruida Controller, doesn't recognize USB

I have a Thunder Laser, Nova24… I talked to the rep at Thunder and he told me to get LightBurn… I told him I wanted to run it on a Mac via USB, he said it shouldn’t be a problem.

I can’t even get it to connect. I plug it in via USB, and it powers the controller, so I know the connection is there, but when I pull up System Information and look under USB, there’s nothing there. I’ve installed the FTDI driver, went through the process of deleting apple’s FTDI driver, still nothing.

Anyone have any advice?

RDWorks sucks, and I’m ready to use a better software.

I don’t understand the issue the way you have described.

Followed by,

Which is it? Connecting with LightBurn or not? Look to the bottom of LightBurn screen to the right of the color palette to see a message displaying your ruida or “No device found”.

Let’s try this:

  1. Did you try the ‘Find my Laser’ feature to complete your setup? What was the result?
  2. If unsuccessful using the Find my Laser tool, did you try to set up a device profile manually?
  3. Are you able to connect to your laser and run jobs from the RDWorks install?
  4. Is this install of RDWorks on the Mac or a different system?

The more information you provide the more chances we can offer help in resolution.

  1. “Find My Laser” recognizes nothing.
  2. I’ve attempted to set up the laser manually many times. Talked directly to Thunder Laser rep who has the same laser and uses LB with his Mac via USB… Still, no connection.
  3. I use RDWorks regularly
  4. RDWorks is running on a Windows computer as RDWorks isn’t supported for Mac.

I’m happy to provide any information, and I’m grateful for any help.

What I meant is that LB shows no connection, but if I plug the USB in to my Mac with the laser powered off, the controller powers up, so that indicates the USB connection is there… Hopefully that clears up the confusion.

Try connecting with a different USB port, and/or power cycling the computer. The FTDI driver for Mac has been known to conflict with Apple’s own internal virtual serial port driver, and it can end up locking out the port.


I have tried this several times. For whatever reason, it doesn’t even show up as a device when I plug it in. I’ve followed the instructions posted below with no avail.

So frustrating.

I’ve tried this method more than once. For whatever reason, it’s doing nothing.

Do you mean it doesn’t show up as a device in your system? Not just in LightBurn? That would be a driver or port issue then. Make sure you’re connected to the correct port, and if that’s correct I’d suggest connecting through a network. It’s a little more effort, but faster, and doesn’t require a device driver.

I don’t have Wifi in my shop. I’m assuming I would need wifi for a network setup.

Thanks for all the input.

Last night, I rebooted the IOS and now everything works fine. I didn’t even have to walk through the FTDI driver switch again.

Who knows.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.