Rudia Koenig Machine not connecting with ethernet

If I’m understanding this correctly you have 2 options to connect to internet, either through wifi or through an ethernet port on the computer. (cable connection)

If that’s the case then your computer probably has 2 IP addresses, one for the ethernet adapter and one for the wifi adapter. If you are connecting to the laser with a cable via the ethernet port then you need to make sure THAT IP address is correct and the one for the wifi adapter is irrelevant.

Ok so now this is confusing me even more. Honestly none of this makes any sense. I only have an ethernet cable, not an adaptor? or are they the same thing, my laser can’t be run through wifi, has to be cable of either usb or ethernet

Hi Sadie, I’m just going to jump in here quickly to say that I am using Lightburn on 2 Macs, (one is new M1 and one is older Intel for the record) and after initially trying to get ethernet connection up and running, I eventually got it working with USB… that was about 2 weeks ago. Now I am having all kinds of funny glitches for a week and yesterday I could only get it to connect after deleting and reinstalling Lightburn on the M1 and this morning the USB will not connect via either Mac. I am about to go and retry the ethernet connection. If I have any success I will let you know what worked for me.

1 Like

Is this how you have things configured on your network?


(*note: Reference Image has been modified. :wink:)

The Laptop representing your Mac?

No, i don’t have a router. As none of the forums actually say you need a router. My modem is in the house, and I am in the garage, so how will i connect the router to the modem?

LightBurn provides direct communication with laser systems via USB or Ethernet. How you bring these together, hard for me to help from here. :slight_smile: I might suggest your supplier could (and should to be fair) offer solutions or a maybe a friend / kid in the neighborhood with a little experience could assist.

Mac USB support requires the proper FTDI driver, which there are known conflicts with what Apple supplies, but can be resolved. We offer several posts here on the forum to help sort this. Try the search to find several worth review, so you get a good overview of the subject. I can help if you don’t find.

To connect to your laser via an Ethernet connections require the proper routing of information as spelled out in this post:

Search will bring up a bunch more as well.

And Bo provides macOS process here:

Regardless of Mac or pc, what you just said is wrong.

Hi Sadie.

Ignore ALL of the above and do the following:

On your Mac settings choose ‘sharing’ and turn on internet sharing from WiFi to Ethernet.

You should then be able to ping and connect to your laser

Nope, just tried that, turned it on to the belkin usb-c LAN, as I have to have an external port as i have a newer mac and of course absolutely nothing…


The top one is my interest, bottom one is the ethernet. I tried manually putting in a different set of numbers, but to no avail. I am so over it haha I called my supplier for the machine and they have said its almost worth just buying a new hp laptop rather than working with mac

For what its worth, I tried all the suggestions here for connecting via Ethernet, and in the end went back to USB, (which had stopped working in the morning) and now its working fine again! :man_facepalming:

Jesus christ, I can’t believe how rude you are. You really know how to make someone feel crap. I didn’t over complicate it. For over a week now I’ve been trying to connect it, and I tried simply connecting and following what you said, and no itdidn’t work. But what did work was using an apple airport router as well as the express, which worked straight away. Maybe next time you try to help someone maybe do it with some decency. Not everyone on here is a network guru. Being nice doesn’t kill believe it or not

I’m not familiar at all with Ruida controllers or Lightburn via ethernet, but I’ve worked with computer networks for the better part of the last 25 years so here’s what you can do to make sure communications are working between your Mac and the Ruida.

  1. In your picture for the Belkin network adapter, change the “Configure IPv4” setting to Static address.
  2. Set the IP address field to 192.168.1.101 (or anything else that is 192.168.1.xxx between 1 and 254, that isn’t 100)
  3. Set the Subnet Mask field to 255.255.255.0
  4. You can leave the Router, DNS Server, and Search domains fields blank as we are only using this link for a host to host connection, so there will be no routing or DNS lookups.
  5. Verify what @Dave01 said about the Ruida having an address of 192.168.1.100. If it is something other than 192.168.1.xxx, then you will have to manually assign the address on the Ruida controller. Again, I’ve never been in front of one so you may have to check the documentation.

Once these items are set, your Mac should talk to the Ruida no problem. You can check this by opening Terminal and issuing the “ping 192.168.1.100” (or whatever the IP address setting is on the Ruida, no quotes) command. You should get continuous response times in milliseconds. If you get any other errors, something isn’t right. Cancel the operation by Command+C and then close the terminal window. Now I have no experience using Lightburn over ethernet so someone else here may be able to enlighten us on how Lightburn chooses what network to use on multi-homed systems, or if it searches all connected networks. You could also turn your wifi off when you are out connected to the laser before opening Lightburn. This way it will only have one network to search.

I hope this helps.

EDIT: I guess I should’ve read the whole post…nevermind… :sweat_smile:

When wanting to connect via Ethernet, you tell LightBurn the address of the device in the ‘Device Profile’. This information is covered in the other post I provided.

How do I connect a Ruida controller with Ethernet?

1 Like

192.168.1.100 is the default IP address for every Ruida controller, and it is static, not DHCP.

Like you said before, but they had a “tech” out there for 8 hours doing god-knows-what.

Trust But Verify :wink:

We agree 100%. The culture we promote is of inclusivity. We strive to offer a welcoming place for members of every knowledge level. Please accept our apology. You are always welcome to post questions. We will do our best to assist, facilitate solutions and provide resolution procedures and workflows, all with the goal of enjoying the lasing experience.

On the original issue, we are here to help. I see some nice ‘step-by-step’ replies to help as well. Update when you can, and we can go from there. :slight_smile:

1 Like

That comes directly from the Ruida CTO. Every Ruida leaves the factory with a default IP address of 192.168.1.100. If the laser machine manufacturer plays with it and changes it, that’s out of their hands. If you default the controller back to factory settings, that’s what you get for an IP address.

All good now guys. I have managed to get my hands on the apple airport extreme and the express which is connected to the machine through ethernet cable and It connect straight away, Mac clearly talks better to Mac products. So I don’t even need a cord going directly to the computer, all wireless:) dad had these just lying around so luckily it didn’t cost me a penny! Thanks for all your help guys :slight_smile:

1 Like

Great! Thank you for hanging in with us. So glad to hear you got this sorted. :slight_smile: