Rudia Koenig Machine not connecting with ethernet

Hi there,

I am about to have a mental break down with this machine and connecting it to lighburn. Brand new Koenig 906 with Rudia. I tried for hours with the USB with my Mac OS catalina 10.15.7 with absolute diddly squat in return. So I have given up on that and tried the ethernet. I have followed all the steps with configuring the IP address. The LAN is showing ON, but can not ping. My IP for my computer is 192.168.0.113 and the laser is192.168.0.133 as i tried192.168.0.13 which also didn’t work. I am at a loss, I just want this machine to connect without having to load everything on to a usb every single time. I have searched this forum thoroughly incase I have missed something but right now I am so disappointed in how hard it has been to simply connect to my laser :frowning:

1 Like

The Ruida controllers are NOT DHCP. Go into the configuration menu and see what it is. You can also set it there. Default is 192.168.1.100

You paid in excess of AU$12K and they walked out leaving you without a working system?

How is your PC connected? Wifi or Ethernet?

How is the laser connected to the network? Directly to your internet router?

There are at least two detailed how-to posts of how to connect a Mac to a Ruida via Ethernet- did you follow either of them?

Did you choose to load drivers after installation? Have you read the issues with Catalina and virtual USB drivers?

Your profile says you spent 5 minutes browsing the forum. That’s probably not long enough, given how much time you probably invested in reasearch in which machine to spend your money on.

I would be fkn pissed-off with Koenig for not leaving you up and running…

I’m in NZ, if necessary I can talk you through it. It’s not difficult, you’re just not doing it right.

How is your PC connected?

There are at least two detailed how-to posts of how to connect a Mac to a Ruida via Ethernet- did you follow either of them?

So the gentleman was here for 8 hours trying to get all my mirrors aligned etc, he spent so long on that he then said just read the forums. I have had this machine for over a week, I have spent almost every night trying to get usb to work and then tried ethernet. So no it wasn’t 5 mins, that must of been from when I signed up my account, I’ve been spending hours reading stuff trying to see where I stuffed up. I am not network savvy. I am illustrator savvy, I know how to design, not any of this.

How is your PC connected? My machine can’t run off WiFi, so my computer is connected to WiFi. But it is connected to the laser via ethernet cable

How is the laser connected to the network? Directly to your internet router? Again, this makes no sense to me, my router for my internet is in the house, I am located in the garage, so Again. Don’t know what I need

There are at least two detailed how-to posts of how to connect a Mac to a Ruida via Ethernet- did you follow either of them? Yes I followed all the instructions in regarding how to get IP address etc, it explains all that, but again still shaking my head

Did you choose to load drivers after installation? Have you read the issues with Catalina and virtual USB drivers? Yes I have read these. I tried drivers, nothing seemed to work, I spent hours trying to sort it

If I’m reading this correctly, you have a WiFi connection from the PC to the house, but have the network cable from the laser to the PC, that won’t work.The laser has to connect to the PC via the USB cable, or direct to your network via the network cable / wireless dongle. Through the PC for the laser on a network cable is a no go.

I’m a PC guy, not a Mac guy, so that’s the best I can do for you.

So the Mac is connected to the wifi in the house. The mac is then connected to the laser via ethernet. The usb did not work. If your saying its a no go then none of the other forums made sense to me… Am i needing another router, because my god this is getting so expensive very quickly just to connect my bloody machine to lightburn hahaha

Thanks for trying anyways. Its getting beyond frustrating, it may seem like its all dummed down but it really isn’t, all the forums don’t actually state if you just put the ethernet in to computer or if you need a router, it just stalks about sorting out the configuration of the IP addresses…

The laser has two ways of connecting. First and fastest is a USB cable directly between the laser and the computer. NOTE: Some lasers have what looks like two USB connections, but one is a ‘U drive’ connection for a thumb drive and the other is an actual USB connection to the computer. They are NOT interchangeable.

The second connection is via a network connection to your home network then back through that to your computer. Unless you get a WiFi dongle for the laser, hard wire is your only option for that connection.

My understanding is that with the proper drivers a Ruida controller can communicate with a Mac via LightBurn. In it’s native format the Ruida controllers are strictly PC machines talking to RDWorks. Somebody here that has a Ruida / Mac set up can probably help more, and in here somewhere is a help section dealing with the Ruida / Mac connection configuration. I believe it’s a matter of loading the proper drivers.

Personally, I do most of my work in Corel, then dump through the software to the laser.

If I’m understanding this correctly you have 2 options to connect to internet, either through wifi or through an ethernet port on the computer. (cable connection)

If that’s the case then your computer probably has 2 IP addresses, one for the ethernet adapter and one for the wifi adapter. If you are connecting to the laser with a cable via the ethernet port then you need to make sure THAT IP address is correct and the one for the wifi adapter is irrelevant.

Ok so now this is confusing me even more. Honestly none of this makes any sense. I only have an ethernet cable, not an adaptor? or are they the same thing, my laser can’t be run through wifi, has to be cable of either usb or ethernet

Hi Sadie, I’m just going to jump in here quickly to say that I am using Lightburn on 2 Macs, (one is new M1 and one is older Intel for the record) and after initially trying to get ethernet connection up and running, I eventually got it working with USB… that was about 2 weeks ago. Now I am having all kinds of funny glitches for a week and yesterday I could only get it to connect after deleting and reinstalling Lightburn on the M1 and this morning the USB will not connect via either Mac. I am about to go and retry the ethernet connection. If I have any success I will let you know what worked for me.

1 Like

Is this how you have things configured on your network?


(*note: Reference Image has been modified. :wink:)

The Laptop representing your Mac?

No, i don’t have a router. As none of the forums actually say you need a router. My modem is in the house, and I am in the garage, so how will i connect the router to the modem?

LightBurn provides direct communication with laser systems via USB or Ethernet. How you bring these together, hard for me to help from here. :slight_smile: I might suggest your supplier could (and should to be fair) offer solutions or a maybe a friend / kid in the neighborhood with a little experience could assist.

Mac USB support requires the proper FTDI driver, which there are known conflicts with what Apple supplies, but can be resolved. We offer several posts here on the forum to help sort this. Try the search to find several worth review, so you get a good overview of the subject. I can help if you don’t find.

To connect to your laser via an Ethernet connections require the proper routing of information as spelled out in this post:

Search will bring up a bunch more as well.

And Bo provides macOS process here:

Regardless of Mac or pc, what you just said is wrong.

Hi Sadie.

Ignore ALL of the above and do the following:

On your Mac settings choose ‘sharing’ and turn on internet sharing from WiFi to Ethernet.

You should then be able to ping and connect to your laser

Nope, just tried that, turned it on to the belkin usb-c LAN, as I have to have an external port as i have a newer mac and of course absolutely nothing…


The top one is my interest, bottom one is the ethernet. I tried manually putting in a different set of numbers, but to no avail. I am so over it haha I called my supplier for the machine and they have said its almost worth just buying a new hp laptop rather than working with mac

For what its worth, I tried all the suggestions here for connecting via Ethernet, and in the end went back to USB, (which had stopped working in the morning) and now its working fine again! :man_facepalming:

This post was flagged by the community and is temporarily hidden.

Jesus christ, I can’t believe how rude you are. You really know how to make someone feel crap. I didn’t over complicate it. For over a week now I’ve been trying to connect it, and I tried simply connecting and following what you said, and no itdidn’t work. But what did work was using an apple airport router as well as the express, which worked straight away. Maybe next time you try to help someone maybe do it with some decency. Not everyone on here is a network guru. Being nice doesn’t kill believe it or not