Lightburn shows disconnected

Suddenly I can’t connect to my laser. It shows “Disconnected” out of nowhere.

I’m running 1.0.04 on a TopWisdom controller. I can’t see the laser when I hit “devices” and hot “Find My Laser”. I’m connected to my PC via USB/Serial port.


It used to be that LightBurn would connect to the controller when you first run the program, and disconnect when you quit. Now, it connects when you send a command or a file, and closes the connection immediately after it’s done using it. This allows you to run multiple copies of the software, and be able to send work from any of them, instead of just the first one. However, we did not update the status thing to show ‘Ready’ continuously after it finds the laser - it probably shows ‘Disconnected’ because technically it is until you’re actively using it. This has been changed and is currently in beta for testing.

Right-click the ‘Devices’ button to reconnect and try to send a file. Please let us know how you get on. :slight_smile:

Tried the right click thing and it didn’t work. Nothing happens. Then when I left click that I get these windows. See attached screenshot.

I had it on the previous version since I avoided the update to 1.0.04 fearing weirdness. Before the laser was sending (and finding the device) but not arriving (no beep, no file at the laser after sending). That was all very new and sudden and nothing worked to fix it after rebooting ,etc. So I updated to the newest version after nothing else worked. That has now made it so the laser is not discovered by the software at all! How do I roll it back to the previous version? I’m going to need my laser for jobs at any time so we need to get her back up and running asap. Open to any advice at all. :grimacing:

Have you actually tried to send a file, or run anything? Another user had this same issue and it turned out that it was just the ‘Ready’ indicator that wasn’t working, but everything else was fine - it simply wasn’t showing that it was fine.

I’ve fixed the Ready indicator for the next release.

For 0.9.21 (I think?) we changed from having the connection to the machine open from the moment you run LightBurn to only being active when you send a command or a file. The ‘Ready’ indicator shows the current status of the connection, so if the laser isn’t always connected, it shows “Disconnected”, which is confusing. I changed that, and made it so it shows “Ready” if it is able to find the controller when you run LightBurn, but I forgot to update the code for TopWisdom and Trocen controllers. This has been fixed for the next release.

I think I may have figured out the problem but I don’t know for sure yet. My Windows updated and I think that affected my drivers. How do I re-install the usb drivers? I’m guessing I may have to re-install the software altogether. Your thoughts? Should I try rolling back my Windows update…?

So I tried (as per the troubleshooting instructions) to uninstalling and reinstalling the lightburn softwars checking the box at the end for the TopWisdom drivers… and that didn’t work. Still doesn’t recognize the device. Going to try uninstalling the windows updates. Will report back.

That didn’t work. So I uninstalled the Windows updates that came before everything went off. That didn’t work. I am wondering if my TopWisdom TL410C controller died (?). If it did I am eyeing the Ruida RDC 6445 upgrade. I will do that if I have to but how do I know it’s definitely a hardware issue? Are there any ways to know or is it just an obvious next step to replace this TopWisdom controller? It’s definitely buggy, but it has worked until now. Replace or not to replace? Thoughts?

Try installing and running AutoLaser (the stock software for that controller). If it doesn’t work, it could be the hardware. If it does, it might’ve installed the driver again and LightBurn could work again too. I’ve seen Windows Update mess up drivers before, so that wouldn’t be unheard of.

1 Like