Lightburn Snap to grid does not do what I would expect

I have a background in drawing vector graphics (both 2D & 3D) and I am having an issue in Lightburn with snap to grid.

Drawing boxes or lines (and circles) I cannot get snap to grid to get the boxes an exact size (not snapping to the grid at all) and this is when drawing or editing.

I know I can set size afterwords but I would much prefer the option to make snap to grid work like other programs. I.E. set grid to say .125" and all boxes should be gridded to that scale (smallest box possible should be .125").

I’ve tried holding down qualifier keys just in case that’s how it works but can’t figure it out. It’s as if it just completely ignores the grid no matter what I am doing. And yes I do have it turned on.

What am I doing wrong? or does it not work the way other programs do?

Thanks

The snap to grid option is set under preferences which is located under the Lightburn menu option. Not only can you set grid snap interval but you can also set a snap to object option and set the visual grid spacing independent of the grid snap spacing.

Snap to grid sizing works while you are dragging out the original object. Once it’s placed, if you grab the scaling handles to adjust, those are not grid snapped. Would that be the issue?

It does not snap when creating. Though I thought it would also snap when editing. I’m using Mac if that makes an difference

NealH yea it’s on and set up. Just does not seem to work

‘Snap to Grid’ does work and it works on the Mac version nicely. What do you have set for ‘Grid Snap Distance’?

Try this, set ‘Visual Grid Spacing’ to 10mm, then set ‘Grid Snap Distance’ to 10mm also. Now select the ‘Create Rectangle’ tool and try to draw a rectangle smaller than a 10mm X 10mm rectangle. :wink:

Sorry, life got in the way so I was not able to test and report back right away.

So, 10mm grid worked (normally use inches) so I went to inches and it failed but I kind of figured it out. Lightburn seems to not like small numbers. I wanted a grid of .125" (1/8") and first it won’t stay set at .125, it switches to .130 but at this size the grid does not work as it should.

So I figure the fix is to switch to metric but it also failed to snap properly. Did go back to inches and then later went back to mm and now it’s working. Sometimes though the numbers I put in change after closing the prefs window.

So, why does inches in small numbers not work? and why does it change the numbers? 1/8" is a pretty standard number to use in CAD but I cannot get it to stay at .125" and it switches to .130" and that grid does not work properly.

I make some very small things and accuracy is important to me and grids are the only way to assure exact accuracy. I do use other programs as well but I like some of the drawing features in Lightburn and am trying to use it exclusively.

More info.

So, I think the issue is more about Lightburn not liking small numbers in inches than anything else. Every time I set .125 for grid and .125 for snap distance it changes the numbers to .130 & .100 respectively. And if I set them both to .25 then the snap distance changes to .30 but the grid stays set to .25

I guess until this is fixed I will switch to metric.

Thanks for reporting this but I am not seeing the same running the latest Mac version. If I set to Inches / Sec, and have Grid Spacing and Grid Snap Distance set to 0.1250, the setting is used and I can draw a 1" X 1" rectangle as shown below.

Can you share some more details so I might be able to reproduce on my end?

Well I almost never use the LB grid, but I was curious enough to give it a try and can confirm that something is wacky. I tried setting the grid and snap to 0.125" and it wouldn’t play nice at all, just as Terry described.

1 Like

I set my grid and snap both to 0.125" and told it OK. A drawn square didn’t snap accurately on 0.125" spacing. I open the edit settings to have a look, and now it says 0.13" for visual and 0.100 for snap distance. What happened to the 0.0125 I set? Repeated several times, got same results.

Linux mint, LB 9.09.

1 Like

What ‘Units’ do you have set, please.

Inches / mm/sec

I want my speeds in mm/sec, but prefer to work in inches.

I’m able to set the grid to 0.1250 as well, and it sticks. I looked through the change history and this is something that’s been fixed, but hasn’t been released yet, so it’ll be in the next version (4 decimal places when in Imperial mode, 2 decimals in metric).

1 Like

Sorry, I pulled the curtain back a little there. :shushing_face: Sorry Oz.

LOL, I think that Oz and the support team are really all the same person, but with different hats…

Edit to add: It’s awesome that the grid problem is already fixed. :slight_smile:

One for all and all for one!

(wait, that’s from a different…) :relaxed:

Glad to know it’s not just me. I’ll deal with metric until the next version.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.