LightBurn stays at busy IMac 7.1 OS El Capitan

Machine K40
Control Cohesion 3D with LCD Control Panel
Firmware is the Smoothieware put out a few months ago

PC is a iMac 7.1 with El Capitan I just installed it from apple today .

Light burn runs fine from my MacBook Pro However I am trying to use an older IMac as my shop computer. I have set it up using the same setup as my MacBook and it say the following in the console :
Waiting for connection…

But obviously it doesn’t home
Is there something different I need to do to get it connected ?
*I have tried re-installing light burn and tried it on a different MacBook Pro and it worked like a charm on the Pro.
*Also it does pick up the laser during the set up but is show Smoothieware (10mmX10MM) at cu.USBmodem3A21 however on the Pro is shows it as a 200mmX300MM

Which OS version are you running? LightBurn requires 10.11 or later, which if I’m not mistaken, is El Capitan. I would suggest checking another USB port, perhaps. I can’t think of anything else that would prevent it from working.

Yes your correct I am using OS 10.11 I upgraded this IMac specifically for LightBurn. It is picking up the Cohesion3D board but it’s just not picking it up correctly. I am willing to bet there is a setting somewhere I need to change on the iMac . I already tried the other ports unfortunately that didn’t work.

Ok So update on this… I sold the 2007 iMac and I now have a 2001 iMac that is running OS 10.13.6. However it is doing the same thing it will not discover the C3D Laser board but both my MacBook Pros will. Maybe I need to run an older version of LightBurn ?

How is the board connected to the Mac? Have you selected a communication port, or are you just waiting for it to auto-choose? You might have to choose one manually.

It’s connected via USB and I tried manual set up and it didn’t connect to it. I also tried restarting the iMac with the K40 powered up and plugged into it. In the past wasn’t there was a selection specifically for C3D? I am thinking there is a command I need to run in terminal to get the USB to recognize it. I saw another post on that and I will try that out.

I had the same problem last week and have put it down to a faulty board, but now I’m going to check some different versions of firmware.

I would think it was the board but it works fine with both my 2012 and 2019 MacBook Pro. I’ll try a few things later today and if it works I’ll post it.

If you’ve got a Cohesion3D board you now choose Smoothieware when setting up a new device. I guess I’ve always selected Create Manually instead of Find My Laser.

I’ve been running an old Mac Pro with 10.11 (El Capitan) for years, but I’ve also used a MacBook Pro with 10.12 (Sierra) and 10.13 (High Sierra) with a Cohesion3D board and haven’t had any connection issues or USB problems…

Same here with the MacBook Pros but for some reason the iMacs I have tried are not wanting to talk to the board.

So I cloned my 2012 MacBook Pro hard drive but still no connection. The iMac doesn’t see it or the camera when I plug it in but USB sticks and hard drives work fine. :face_with_symbols_over_mouth: could it be because they are USB 2.0?

That is odd… Any chance you’ve got a USB hub you can test it with? I usually have a few on hand (newer ones, older ones, some powered, some not powered) that I keep around for testing things when I run across strange USB connection issues.

I don’t have any on hand but I was looking at getting a thunderbolt 2 to USB hub but they are over $150 so I want to be sure that’s the issue first .

Solved —— The issue in fact was the the stock 2.0 USBs in the iMac. So if you are using a 2007 -2011 iMac you will have to use a thunderbolt 2 USB dock. If you are using a Cohesion3D board. —— Solved


Thanks for updating the thread with that - much appreciated.

As the Cohesion is also USB 2.0, I suspect a different problem, masked by using a thunderbolt>USB hub.

Mac USB iteration is sound - but the drivers for FTDI, etc. have been problematic, especially when they hang around alongside the Mac OS OEM ones.

Ok take away the 2.0 … I used two different iMacs and this solved the problem

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.